summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-16 15:24:15 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-16 15:37:57 +0100
commit164e2b33f2cdb1ea26121ede08c15dd4cdf97b65 (patch)
tree3c2e070c4a41a615638353e4a8d263932d7638be /dev-python/pytest-virtualenv
parentapp-portage/gpyutils: Set DISTUTILS_USE_SETUPTOOLS, sync live (diff)
downloadgentoo-164e2b33f2cdb1ea26121ede08c15dd4cdf97b65.tar.gz
gentoo-164e2b33f2cdb1ea26121ede08c15dd4cdf97b65.tar.bz2
gentoo-164e2b33f2cdb1ea26121ede08c15dd4cdf97b65.zip
dev-python/pytest-virtualenv: Set DISTUTILS_USE_SETUPTOOLS
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-virtualenv')
-rw-r--r--dev-python/pytest-virtualenv/pytest-virtualenv-1.7.0.ebuild7
1 files changed, 2 insertions, 5 deletions
diff --git a/dev-python/pytest-virtualenv/pytest-virtualenv-1.7.0.ebuild b/dev-python/pytest-virtualenv/pytest-virtualenv-1.7.0.ebuild
index 0f53a35b999e..ce2151787c0a 100644
--- a/dev-python/pytest-virtualenv/pytest-virtualenv-1.7.0.ebuild
+++ b/dev-python/pytest-virtualenv/pytest-virtualenv-1.7.0.ebuild
@@ -2,6 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
PYTHON_COMPAT=( python{2_7,3_{5,6,7}} pypy{,3} )
inherit distutils-r1
@@ -13,22 +15,17 @@ SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~mips ~s390 ~sparc ~x86"
-IUSE="test"
RDEPEND="
dev-python/pytest-fixture-config[${PYTHON_USEDEP}]
dev-python/pytest-shutil[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/virtualenv[${PYTHON_USEDEP}]
"
BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
test? (
- ${RDEPEND}
dev-python/mock[${PYTHON_USEDEP}]
)
"
-RESTRICT="!test? ( test )"
distutils_enable_tests setup.py