summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-16 22:06:11 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-16 22:09:42 +0100
commitd07170b47698004fd850f5255ea9b703c369f5d6 (patch)
treef84d1c822d1a9cbf52e61adbe785231a72cdde27 /dev-python/pytest
parentdev-python/mock: Replace virts with cond deps (diff)
downloadgentoo-d07170b47698004fd850f5255ea9b703c369f5d6.tar.gz
gentoo-d07170b47698004fd850f5255ea9b703c369f5d6.tar.bz2
gentoo-d07170b47698004fd850f5255ea9b703c369f5d6.zip
dev-python/pytest: Replace virts with cond deps
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest')
-rw-r--r--dev-python/pytest/pytest-3.10.1.ebuild12
-rw-r--r--dev-python/pytest/pytest-4.5.0.ebuild8
-rw-r--r--dev-python/pytest/pytest-4.6.9.ebuild8
3 files changed, 17 insertions, 11 deletions
diff --git a/dev-python/pytest/pytest-3.10.1.ebuild b/dev-python/pytest/pytest-3.10.1.ebuild
index c4d2de67cde7..10c1bb79f5c6 100644
--- a/dev-python/pytest/pytest-3.10.1.ebuild
+++ b/dev-python/pytest/pytest-3.10.1.ebuild
@@ -25,15 +25,17 @@ PY_VER="1.5.0"
RDEPEND="
>=dev-python/atomicwrites-1.0[${PYTHON_USEDEP}]
>=dev-python/attrs-17.4.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '>=dev-python/more-itertools-4.0.0[${PYTHON_USEDEP}]' python2_7 )
- $(python_gen_cond_dep '<dev-python/more-itertools-6.0.0[${PYTHON_USEDEP}]' python2_7 )
+ $(python_gen_cond_dep '
+ >=dev-python/more-itertools-4.0.0[${PYTHON_USEDEP}]
+ <dev-python/more-itertools-6.0.0[${PYTHON_USEDEP}]
+ dev-python/funcsigs[${PYTHON_USEDEP}]
+ dev-python/pathlib2[${PYTHON_USEDEP}]
+ ' -2)
$(python_gen_cond_dep '>=dev-python/more-itertools-4.0.0[${PYTHON_USEDEP}]' python3_{6,7} pypy{,3} )
- $(python_gen_cond_dep 'dev-python/pathlib2[${PYTHON_USEDEP}]' python2_7)
>=dev-python/pluggy-0.7[${PYTHON_USEDEP}]
>=dev-python/py-${PY_VER}[${PYTHON_USEDEP}]
>=dev-python/setuptools-40[${PYTHON_USEDEP}]
- >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
- virtual/python-funcsigs[${PYTHON_USEDEP}]"
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]"
# flake & pytest-capturelog cause a number of tests to fail
DEPEND="${RDEPEND}
diff --git a/dev-python/pytest/pytest-4.5.0.ebuild b/dev-python/pytest/pytest-4.5.0.ebuild
index f9bfdba1a65a..a54b3397dcf6 100644
--- a/dev-python/pytest/pytest-4.5.0.ebuild
+++ b/dev-python/pytest/pytest-4.5.0.ebuild
@@ -26,14 +26,16 @@ RDEPEND="
>=dev-python/atomicwrites-1.0[${PYTHON_USEDEP}]
>=dev-python/attrs-17.4.0[${PYTHON_USEDEP}]
>=dev-python/more-itertools-4.0.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/pathlib2[${PYTHON_USEDEP}]' python2_7)
+ $(python_gen_cond_dep '
+ dev-python/pathlib2[${PYTHON_USEDEP}]
+ dev-python/funcsigs[${PYTHON_USEDEP}]
+ ' -2)
>=dev-python/pluggy-0.11[${PYTHON_USEDEP}]
<dev-python/pluggy-1
>=dev-python/py-${PY_VER}[${PYTHON_USEDEP}]
>=dev-python/setuptools-40[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
- dev-python/wcwidth[${PYTHON_USEDEP}]
- virtual/python-funcsigs[${PYTHON_USEDEP}]"
+ dev-python/wcwidth[${PYTHON_USEDEP}]"
# flake cause a number of tests to fail
DEPEND="${RDEPEND}
diff --git a/dev-python/pytest/pytest-4.6.9.ebuild b/dev-python/pytest/pytest-4.6.9.ebuild
index fe23e76eb74b..c4912d16a924 100644
--- a/dev-python/pytest/pytest-4.6.9.ebuild
+++ b/dev-python/pytest/pytest-4.6.9.ebuild
@@ -28,14 +28,16 @@ RDEPEND="
>=dev-python/more-itertools-4.0.0[${PYTHON_USEDEP}]
$(python_gen_cond_dep 'dev-python/importlib_metadata[${PYTHON_USEDEP}]' \
-2 python3_{5,6,7} pypy3)
- $(python_gen_cond_dep 'dev-python/pathlib2[${PYTHON_USEDEP}]' -2)
+ $(python_gen_cond_dep '
+ dev-python/pathlib2[${PYTHON_USEDEP}]
+ dev-python/funcsigs[${PYTHON_USEDEP}]
+ ' -2)
>=dev-python/pluggy-0.12[${PYTHON_USEDEP}]
<dev-python/pluggy-1
>=dev-python/py-${PY_VER}[${PYTHON_USEDEP}]
dev-python/packaging[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
- dev-python/wcwidth[${PYTHON_USEDEP}]
- virtual/python-funcsigs[${PYTHON_USEDEP}]"
+ dev-python/wcwidth[${PYTHON_USEDEP}]"
# flake cause a number of tests to fail
DEPEND="