summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-14 09:51:33 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-14 10:25:51 +0200
commit5677870c809d7bd5b0c1147489424e2a06046782 (patch)
tree442d235e4f4110eb704122e0296995a64c307b9f /dev-python/python-bugzilla
parentsys-apps/file: Enable py3.11 (diff)
downloadgentoo-5677870c809d7bd5b0c1147489424e2a06046782.tar.gz
gentoo-5677870c809d7bd5b0c1147489424e2a06046782.tar.bz2
gentoo-5677870c809d7bd5b0c1147489424e2a06046782.zip
dev-python/python-bugzilla: Use PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-bugzilla')
-rw-r--r--dev-python/python-bugzilla/python-bugzilla-3.2.0-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/python-bugzilla/python-bugzilla-3.2.0-r1.ebuild b/dev-python/python-bugzilla/python-bugzilla-3.2.0-r1.ebuild
new file mode 100644
index 000000000000..39e9816a074b
--- /dev/null
+++ b/dev-python/python-bugzilla/python-bugzilla-3.2.0-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A python module for interacting with Bugzilla over XMLRPC"
+HOMEPAGE="
+ https://github.com/python-bugzilla/python-bugzilla/
+ https://pypi.org/project/python-bugzilla/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+LICENSE="GPL-2+"
+SLOT="0"
+
+RDEPEND="
+ || (
+ dev-python/python-magic[${PYTHON_USEDEP}]
+ sys-apps/file[python,${PYTHON_USEDEP}]
+ )
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest