summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2019-03-17 12:21:40 +0300
committerMikle Kolyada <zlogene@gentoo.org>2019-03-17 14:11:33 +0300
commitd43c696a0023b586d5e2102355c00c15b036b0a6 (patch)
tree5fdb27598cf2c8bd8f2e6cbbbadb53f76b98c528 /dev-python/python-caja
parentmate-base/mate: Version bump (v1.22.0) (diff)
downloadgentoo-d43c696a0023b586d5e2102355c00c15b036b0a6.tar.gz
gentoo-d43c696a0023b586d5e2102355c00c15b036b0a6.tar.bz2
gentoo-d43c696a0023b586d5e2102355c00c15b036b0a6.zip
dev-python/python-caja: Version bump (v1.22.0)
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'dev-python/python-caja')
-rw-r--r--dev-python/python-caja/Manifest1
-rw-r--r--dev-python/python-caja/python-caja-1.22.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/python-caja/Manifest b/dev-python/python-caja/Manifest
index 865bc68448a8..4f66acd609a2 100644
--- a/dev-python/python-caja/Manifest
+++ b/dev-python/python-caja/Manifest
@@ -1 +1,2 @@
DIST python-caja-1.18.1.tar.xz 284020 BLAKE2B 9513c89450c07330471b2ee9a9d9644eef33858060e66054ab00fb16d3d63292e14704c9f80d7cd5928fcf108bb1cf8c5afd7eb8713814554574cda39b0a8960 SHA512 5907f0769e43b592228aa66f9b51e227a414051975066c16734397afa05c1235d442c625bb00a51e9356768fc3b9f46cfca51e9563e4368b39a8e58a9e514e7d
+DIST python-caja-1.22.0.tar.xz 288324 BLAKE2B 11649dc0d201e9bc0063ad8845ccf0ac7b474e87edce1938311723687253c73058f2411170897acf80e4166169ad2675afff171c31808b22269dcdf857954fa1 SHA512 36ac6feec8dbff345d5657d0bc9eceed7a58648c104ce309f20aaff18cedd8822fb8bc0c13662796d15391af72285fa3ae4185043cce9e471f22a2868f37cc2c
diff --git a/dev-python/python-caja/python-caja-1.22.0.ebuild b/dev-python/python-caja/python-caja-1.22.0.ebuild
new file mode 100644
index 000000000000..132eed353b9e
--- /dev/null
+++ b/dev-python/python-caja/python-caja-1.22.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MATE_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit mate python-single-r1
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="Python bindings for the Caja file manager"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="doc"
+
+COMMON_DEPEND="${PYTHON_DEPS}
+ >=dev-libs/glib-2.50:2
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ >=mate-base/caja-1.17.1[introspection]
+ >=x11-libs/gtk+-3.22:3"
+
+RDEPEND="${COMMON_DEPEND}"
+
+DEPEND="${COMMON_DEPEND}
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ virtual/pkgconfig:*
+ doc? ( app-text/docbook-xml-dtd:4.1.2 )"
+
+src_install() {
+ mate_src_install
+
+ # Keep the directory for systemwide extensions.
+ keepdir /usr/share/python-caja/extensions/
+
+ # The HTML documentation generation is broken and commented out by upstream.
+ #
+ #if use doc ; then
+ # insinto /usr/share/gtk-doc/html/nautilus-python # for dev-util/devhelp
+ # doins -r docs/html/*
+ #fi
+}