summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-05-07 10:08:39 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-05-07 10:09:27 -0700
commit8f3e5c0645c6675ff823eeb312aa3052b6a479bf (patch)
tree12a48893761e3e4ec32b820ca20cfa17b4e51619 /dev-python/python-cstruct/python-cstruct-1.8.ebuild
parentmedia-libs/libaom: mirror file (diff)
downloadgentoo-8f3e5c0645c6675ff823eeb312aa3052b6a479bf.tar.gz
gentoo-8f3e5c0645c6675ff823eeb312aa3052b6a479bf.tar.bz2
gentoo-8f3e5c0645c6675ff823eeb312aa3052b6a479bf.zip
dev-python/python-cstruct-1.8: Version bump, EAPI=7, add py38
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/python-cstruct/python-cstruct-1.8.ebuild')
-rw-r--r--dev-python/python-cstruct/python-cstruct-1.8.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/python-cstruct/python-cstruct-1.8.ebuild b/dev-python/python-cstruct/python-cstruct-1.8.ebuild
new file mode 100644
index 000000000000..a7870977d0da
--- /dev/null
+++ b/dev-python/python-cstruct/python-cstruct-1.8.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=manual
+inherit distutils-r1
+
+DESCRIPTION="C-style structs for Python"
+HOMEPAGE="https://github.com/andreax79/python-cstruct https://pypi.org/project/cstruct/"
+SRC_URI="https://github.com/andreax79/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# define setuptools dep manually to avoid warning
+# setup.py contains entry_points, but it's an empty string
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS=( README.md )
+
+distutils_enable_tests setup.py