summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-22 17:51:31 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-22 17:53:03 +0200
commit13372d6b46b2c07e5ccb44d335f78bc6cc79b1ab (patch)
tree8348346d56e1f834414de81765aefe319adeee86 /dev-python/python-email-validator
parentdev-python/prompt_toolkit: Remove old (diff)
downloadgentoo-13372d6b46b2c07e5ccb44d335f78bc6cc79b1ab.tar.gz
gentoo-13372d6b46b2c07e5ccb44d335f78bc6cc79b1ab.tar.bz2
gentoo-13372d6b46b2c07e5ccb44d335f78bc6cc79b1ab.zip
dev-python/python-email-validator: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-email-validator')
-rw-r--r--dev-python/python-email-validator/Manifest2
-rw-r--r--dev-python/python-email-validator/python-email-validator-1.1.3.ebuild39
-rw-r--r--dev-python/python-email-validator/python-email-validator-1.2.1.ebuild44
3 files changed, 0 insertions, 85 deletions
diff --git a/dev-python/python-email-validator/Manifest b/dev-python/python-email-validator/Manifest
index cf4b72441739..cdfa6655d652 100644
--- a/dev-python/python-email-validator/Manifest
+++ b/dev-python/python-email-validator/Manifest
@@ -1,3 +1 @@
-DIST python-email-validator-1.1.3.tar.gz 19863 BLAKE2B 10700b4c6a48c50095045b6e3c9218cd565776b26e17c1c043633e208b9fbd346162cedaa4a1116ec2fccf63b4383438c7e1aef6faf9d2ead5512af7f934675c SHA512 d9087bf56783daf389909e13652a9db8f0408badf454f6239aa20f6a5e9510619d3662cf1567a03d0b14c4bbe81644509cd12975b2aa1b544d644b6c2b2854f4
-DIST python-email-validator-1.2.1.gh.tar.gz 24348 BLAKE2B 7cd19c07bd0b8c467c0f0ec15376f0677305c6025eff5a86854dfd7cad3fe6971e218e724d86d4040af3f590fe5e841e469dea7dc8526031dccb494845848630 SHA512 e758518ef114e08cca0f83c681e6ff7ec6fad54c1e0bba727ee0f8917e93040ed3873ba0207e21a4830208d98637937294c5c28d67c317dc4ad3351c7d3f99a4
DIST python-email-validator-1.3.0.gh.tar.gz 28555 BLAKE2B 7b13b4093be2b97260d01c562a205d299570e63bfba2f8e411000bc19319e9b538e95f2f4d33962b03fe5dc47c3690b8a0134b792f6822386ab6b20b260a991e SHA512 b10139f8eb221fa15a12c44f2c87d17449e317c6edfd4c6a99dc122a9178dcc4c3ef20f99f0feefb6a5b4a9460169b22d835871d2be88efd59f1474ff3d9aa06
diff --git a/dev-python/python-email-validator/python-email-validator-1.1.3.ebuild b/dev-python/python-email-validator/python-email-validator-1.1.3.ebuild
deleted file mode 100644
index 530a94309ad7..000000000000
--- a/dev-python/python-email-validator/python-email-validator-1.1.3.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-inherit distutils-r1
-
-DESCRIPTION="A robust email syntax and deliverability validation library"
-HOMEPAGE="https://github.com/JoshData/python-email-validator"
-SRC_URI="https://github.com/JoshData/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="CC0-1.0"
-KEYWORDS="amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-SLOT="0"
-
-RDEPEND="
- >=dev-python/idna-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/dnspython-1.15.0[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local deselect=(
- # these tests rely on access to gmail.com
- tests/test_main.py::test_deliverability_no_records
- tests/test_main.py::test_deliverability_found
- tests/test_main.py::test_deliverability_fails
- tests/test_main.py::test_validate_email__with_caching_resolver
- tests/test_main.py::test_validate_email__with_configured_resolver
- # these tests rely on example.com being resolvable
- tests/test_main.py::test_main_single_good_input
- tests/test_main.py::test_main_multi_input
- tests/test_main.py::test_main_input_shim
- )
-
- epytest ${deselect[@]/#/--deselect }
-}
diff --git a/dev-python/python-email-validator/python-email-validator-1.2.1.ebuild b/dev-python/python-email-validator/python-email-validator-1.2.1.ebuild
deleted file mode 100644
index 3e5b04ba445d..000000000000
--- a/dev-python/python-email-validator/python-email-validator-1.2.1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="A robust email syntax and deliverability validation library"
-HOMEPAGE="
- https://github.com/JoshData/python-email-validator/
- https://pypi.org/project/email-validator/
-"
-SRC_URI="
- https://github.com/JoshData/python-email-validator/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="CC0-1.0"
-KEYWORDS="amd64 arm arm64 hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc x86"
-SLOT="0"
-
-RDEPEND="
- >=dev-python/idna-2.8[${PYTHON_USEDEP}]
- >=dev-python/dnspython-1.15.0[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # these tests rely on access to gmail.com
- tests/test_main.py::test_deliverability_found
- tests/test_main.py::test_deliverability_fails
- # these tests rely on example.com being resolvable
- "tests/test_main.py::test_email_example_reserved_domain[me@mail.example]"
- "tests/test_main.py::test_email_example_reserved_domain[me@example.com]"
- "tests/test_main.py::test_email_example_reserved_domain[me@mail.example.com]"
- tests/test_main.py::test_validate_email__with_caching_resolver
- tests/test_main.py::test_main_single_good_input
- tests/test_main.py::test_main_multi_input
- tests/test_main.py::test_main_input_shim
-)