summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-20 05:00:23 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-20 05:00:23 +0200
commitd578b4279120fc40a6071f539e2ad4373d632819 (patch)
treebc43aec0b7051408a6d8bb1b06a081b1546951f2 /dev-python/python-engineio
parentdev-python/cfn-lint: Bump to 0.77.2 (diff)
downloadgentoo-d578b4279120fc40a6071f539e2ad4373d632819.tar.gz
gentoo-d578b4279120fc40a6071f539e2ad4373d632819.tar.bz2
gentoo-d578b4279120fc40a6071f539e2ad4373d632819.zip
dev-python/python-engineio: Bump to 4.4.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-engineio')
-rw-r--r--dev-python/python-engineio/Manifest1
-rw-r--r--dev-python/python-engineio/python-engineio-4.4.1.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/python-engineio/Manifest b/dev-python/python-engineio/Manifest
index 745fb1d04195..0b773e63d3b5 100644
--- a/dev-python/python-engineio/Manifest
+++ b/dev-python/python-engineio/Manifest
@@ -1 +1,2 @@
DIST python-engineio-4.4.0.gh.tar.gz 309353 BLAKE2B 4cf40802fddcce2e53e205bdbe73bdf0ec822e15581fe4a9939b8d05c3eb6ba82a99d089d4708169b197aa79e5b5f14001ff86f72025fc6d96c99ed6d73fe620 SHA512 b7995aaf2583ec58ac87f048608653ade3846dd103616ee90b3dc12cc7e27c7d37959cd3e1ebf6e138395ff6fad8cd011407b6660258715e513bf72c8a3e1f6f
+DIST python-engineio-4.4.1.gh.tar.gz 309475 BLAKE2B 4ae5dd9887f4d3a70d4983d2a0f0de29b1a54d30961bfc430b8850ff4af73fa1cd9abad6caeb8248a44def42b02e26ecb0632dd9b4d57e2a7f44b33762659304 SHA512 a903ae4f5a4679f6d46fda09901b637ef8dcf2896ece8781460d27aab7c8da606e16a89ac5dea94c156d8196a7e931626b2310b41ddc61d4241b5e004ad2ca64
diff --git a/dev-python/python-engineio/python-engineio-4.4.1.ebuild b/dev-python/python-engineio/python-engineio-4.4.1.ebuild
new file mode 100644
index 000000000000..a47389eb7079
--- /dev/null
+++ b/dev-python/python-engineio/python-engineio-4.4.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of the Engine.IO realtime server"
+HOMEPAGE="
+ https://python-engineio.readthedocs.io/
+ https://github.com/miguelgrinberg/python-engineio/
+ https://pypi.org/project/python-engineio/"
+SRC_URI="
+ https://github.com/miguelgrinberg/python-engineio/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/websocket-client[${PYTHON_USEDEP}]
+"
+# Can use eventlet, werkzeug, or gevent, but no tests for werkzeug
+BDEPEND="
+ test? (
+ dev-python/tornado[${PYTHON_USEDEP}]
+ dev-python/websockets[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/alabaster
+
+EPYTEST_IGNORE=(
+ # eventlet is masked for removal
+ tests/common/test_async_eventlet.py
+)
+
+EPYTEST_DESELECT=(
+ # also eventlet
+ tests/common/test_server.py::TestServer::test_async_mode_eventlet
+ tests/common/test_server.py::TestServer::test_connect
+ tests/common/test_server.py::TestServer::test_service_task_started
+ tests/common/test_server.py::TestServer::test_upgrades
+)