summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-06-08 21:47:58 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-06-08 22:24:07 +0200
commit53e0f5cb69d174d980867e4a0218abc9210e6479 (patch)
treed51adbe5c01523ed0a67265b94b1504f7706747a /dev-python/python-evdev
parentapp-i18n/opencc: Stabilize 1.1.3 ppc64, #850637 (diff)
downloadgentoo-53e0f5cb69d174d980867e4a0218abc9210e6479.tar.gz
gentoo-53e0f5cb69d174d980867e4a0218abc9210e6479.tar.bz2
gentoo-53e0f5cb69d174d980867e4a0218abc9210e6479.zip
dev-python/python-evdev: enable py3.11
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/python-evdev')
-rw-r--r--dev-python/python-evdev/files/python-evdev-1.5.0-python311.patch14
-rw-r--r--dev-python/python-evdev/python-evdev-1.5.0.ebuild7
2 files changed, 20 insertions, 1 deletions
diff --git a/dev-python/python-evdev/files/python-evdev-1.5.0-python311.patch b/dev-python/python-evdev/files/python-evdev-1.5.0-python311.patch
new file mode 100644
index 000000000000..1f516c79acb2
--- /dev/null
+++ b/dev-python/python-evdev/files/python-evdev-1.5.0-python311.patch
@@ -0,0 +1,14 @@
+diff --git a/evdev/eventio_async.py b/evdev/eventio_async.py
+index 77542a4..68225c3 100644
+--- a/evdev/eventio_async.py
++++ b/evdev/eventio_async.py
+@@ -85,8 +85,7 @@ class ReadIterator(object):
+ def __aiter__(self):
+ return self
+
+- @asyncio.coroutine
+- def __anext__(self):
++ async def __anext__(self):
+ future = asyncio.Future()
+ try:
+ # Read from the previous batch of events.
diff --git a/dev-python/python-evdev/python-evdev-1.5.0.ebuild b/dev-python/python-evdev/python-evdev-1.5.0.ebuild
index a1df11de9086..3d0340816d88 100644
--- a/dev-python/python-evdev/python-evdev-1.5.0.ebuild
+++ b/dev-python/python-evdev/python-evdev-1.5.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..11} )
inherit distutils-r1
@@ -21,6 +21,11 @@ KEYWORDS="amd64 ~arm x86"
distutils_enable_tests pytest
+PATCHES=(
+ # https://github.com/gvalkov/python-evdev/pull/174
+ "${FILESDIR}/${P}-python311.patch"
+)
+
EPYTEST_DESELECT=(
tests/test_uinput.py
)