summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-08-31 13:40:37 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-08-31 15:55:40 +0300
commitbcbf1318f03eaddc40d4feeccd4506ba57579f9a (patch)
tree37ac53df885bff88fc73351477b6d14661dc51f9 /dev-python/python-glanceclient/python-glanceclient-3.2.2-r1.ebuild
parentmozlinguas-v2.eclass: Support waterfox (diff)
downloadgentoo-bcbf1318f03eaddc40d4feeccd4506ba57579f9a.tar.gz
gentoo-bcbf1318f03eaddc40d4feeccd4506ba57579f9a.tar.bz2
gentoo-bcbf1318f03eaddc40d4feeccd4506ba57579f9a.zip
dev-python/python-glanceclient: enable py3.9, enable tests
Closes: https://bugs.gentoo.org/798360 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/python-glanceclient/python-glanceclient-3.2.2-r1.ebuild')
-rw-r--r--dev-python/python-glanceclient/python-glanceclient-3.2.2-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/python-glanceclient/python-glanceclient-3.2.2-r1.ebuild b/dev-python/python-glanceclient/python-glanceclient-3.2.2-r1.ebuild
new file mode 100644
index 000000000000..e0999c504f89
--- /dev/null
+++ b/dev-python/python-glanceclient/python-glanceclient-3.2.2-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Glance API"
+HOMEPAGE="https://github.com/openstack/python-glanceclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/keystoneauth-3.6.2[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-17.1.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/warlock-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/warlock-2[${PYTHON_USEDEP}]
+ >=dev-python/wrapt-1.7.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/ddt[${PYTHON_USEDEP}]
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ dev-python/stestr[${PYTHON_USEDEP}]
+ dev-python/testscenarios[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ "${EPYTHON}" -m stestr run --debug || die "Tests failed with ${EPYTHON}"
+}