summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Bock <nicolasbock@gentoo.org>2018-01-02 07:44:30 -0700
committerNicolas Bock <nicolasbock@gentoo.org>2018-01-02 07:45:27 -0700
commitf0ac4e6e53dc44334de4c9ea7e0fc5f704d2ba6c (patch)
tree2ca2019b64b7f52f13dac12d5c835ebd55d3e3a3 /dev-python/python-hpilo/python-hpilo-4.0.ebuild
parentsys-fs/udftools: Removed old. (diff)
downloadgentoo-f0ac4e6e53dc44334de4c9ea7e0fc5f704d2ba6c.tar.gz
gentoo-f0ac4e6e53dc44334de4c9ea7e0fc5f704d2ba6c.tar.bz2
gentoo-f0ac4e6e53dc44334de4c9ea7e0fc5f704d2ba6c.zip
dev-python/python-hpilo: New package
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'dev-python/python-hpilo/python-hpilo-4.0.ebuild')
-rw-r--r--dev-python/python-hpilo/python-hpilo-4.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/python-hpilo/python-hpilo-4.0.ebuild b/dev-python/python-hpilo/python-hpilo-4.0.ebuild
new file mode 100644
index 000000000000..a291d1ad427b
--- /dev/null
+++ b/dev-python/python-hpilo/python-hpilo-4.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="iLO automation from python or shell"
+HOMEPAGE="https://pypi.python.org/pypi/python-hpilo"
+SRC_URI="https://github.com/seveas/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+python_test() {
+ ${EPYTHON} -m unittest discover || die
+}