summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarty E. Plummer <hanetzer@startmail.com>2018-04-27 19:23:29 -0500
committerMichał Górny <mgorny@gentoo.org>2018-04-29 12:29:48 +0200
commitdcfa42ebd72fbda1c401cb97c4a30fa7070c8c10 (patch)
tree73e5d16b704c45a3b49ffc324cb3f89ae9044741 /dev-python/python-ldap/python-ldap-2.4.32.ebuild
parentdev-python/ws4py: git-2->git-r3 (diff)
downloadgentoo-dcfa42ebd72fbda1c401cb97c4a30fa7070c8c10.tar.gz
gentoo-dcfa42ebd72fbda1c401cb97c4a30fa7070c8c10.tar.bz2
gentoo-dcfa42ebd72fbda1c401cb97c4a30fa7070c8c10.zip
dev-python/python-ldap: git-2->git-r3
Closes: https://bugs.gentoo.org/458558 Closes: https://github.com/gentoo/gentoo/pull/8176 Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'dev-python/python-ldap/python-ldap-2.4.32.ebuild')
-rw-r--r--dev-python/python-ldap/python-ldap-2.4.32.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/dev-python/python-ldap/python-ldap-2.4.32.ebuild b/dev-python/python-ldap/python-ldap-2.4.32.ebuild
index c43b6bc092ca..623b5213fb84 100644
--- a/dev-python/python-ldap/python-ldap-2.4.32.ebuild
+++ b/dev-python/python-ldap/python-ldap-2.4.32.ebuild
@@ -10,11 +10,16 @@ inherit distutils-r1 multilib
DESCRIPTION="Various LDAP-related Python modules"
HOMEPAGE="https://www.python-ldap.org/en/latest/
https://pypi.org/project/python-ldap/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/xmw/python-ldap.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-solaris"
+fi
LICENSE="PSF-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-solaris"
IUSE="examples sasl ssl"
# If you need support for openldap-2.3.x, please use python-ldap-2.3.9.
@@ -26,7 +31,8 @@ RDEPEND=">net-nds/openldap-2.4.11
dev-python/pyasn1-modules[${PYTHON_USEDEP}]
sasl? ( >=dev-libs/cyrus-sasl-2.1 )"
DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
RDEPEND+=" !dev-python/pyldap"
python_prepare_all() {