summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-10-13 21:56:46 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-10-13 22:02:12 +0300
commit49600b1d3891c41eb743d32a988bf2863ef8fe9a (patch)
tree8325aa5d22c4b4f2ce32886f9422f03a2a5ce59a /dev-python/python-libevdev
parentdev-libs/libevdev: enable py3.10 (diff)
downloadgentoo-49600b1d3891c41eb743d32a988bf2863ef8fe9a.tar.gz
gentoo-49600b1d3891c41eb743d32a988bf2863ef8fe9a.tar.bz2
gentoo-49600b1d3891c41eb743d32a988bf2863ef8fe9a.zip
dev-python/python-libevdev: enable py3.10, use d_e_t
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/python-libevdev')
-rw-r--r--dev-python/python-libevdev/python-libevdev-0.9.ebuild12
1 files changed, 3 insertions, 9 deletions
diff --git a/dev-python/python-libevdev/python-libevdev-0.9.ebuild b/dev-python/python-libevdev/python-libevdev-0.9.ebuild
index a01db655c3fb..f3aa23875acf 100644
--- a/dev-python/python-libevdev/python-libevdev-0.9.ebuild
+++ b/dev-python/python-libevdev/python-libevdev-0.9.ebuild
@@ -2,8 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Python wrappers for the libevdev library"
@@ -13,14 +13,8 @@ SRC_URI="https://gitlab.freedesktop.org/libevdev/${PN}/-/archive/${PV}/${P}.tar.
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-DEPEND="
- test? ( dev-libs/libevdev )
-"
+BDEPEND="test? ( dev-libs/libevdev )"
PDEPEND="dev-libs/libevdev"
-python_test() {
- esetup.py test
-}
+distutils_enable_tests unittest