summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <junghans@gentoo.org>2019-03-01 15:16:32 -0700
committerChristoph Junghans <junghans@gentoo.org>2019-03-01 15:24:15 -0700
commitbdb754b55af0f51ccc589aad74a23f85e1f245bc (patch)
treeb176e03a12cff312676eab4090f2b0d35084d973 /dev-python/python-pluginloader
parentdev-util/cmake: Bump to version 3.14.0_rc3. Removed old. (diff)
downloadgentoo-bdb754b55af0f51ccc589aad74a23f85e1f245bc.tar.gz
gentoo-bdb754b55af0f51ccc589aad74a23f85e1f245bc.tar.bz2
gentoo-bdb754b55af0f51ccc589aad74a23f85e1f245bc.zip
dev-python/python-pluginloader: initial commit
Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Christoph Junghans <junghans@gentoo.org>
Diffstat (limited to 'dev-python/python-pluginloader')
-rw-r--r--dev-python/python-pluginloader/Manifest1
-rw-r--r--dev-python/python-pluginloader/metadata.xml11
-rw-r--r--dev-python/python-pluginloader/python-pluginloader-1.0.0.ebuild20
3 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/python-pluginloader/Manifest b/dev-python/python-pluginloader/Manifest
new file mode 100644
index 000000000000..f0600554fb3e
--- /dev/null
+++ b/dev-python/python-pluginloader/Manifest
@@ -0,0 +1 @@
+DIST python-pluginloader-1.0.0.tar.gz 4625 BLAKE2B 6da2fe78d09943e56df8331c3c0ca399f6e29d10c38c1408d49954cf2f272fa0876391f27b5553a0183541ee642570a47af97c17f441b4f964721dd2fecc1b10 SHA512 879ff3eb1ff9280a4a580f24903b4f449910ec34b7e3b08215c86cc81e9c65ec48279143ac0ed8564478d1c013074c8165f6a85b43bf08760c83dda78a19f246
diff --git a/dev-python/python-pluginloader/metadata.xml b/dev-python/python-pluginloader/metadata.xml
new file mode 100644
index 000000000000..6b761d971220
--- /dev/null
+++ b/dev-python/python-pluginloader/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">magmax/python-pluginloader</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-pluginloader/python-pluginloader-1.0.0.ebuild b/dev-python/python-pluginloader/python-pluginloader-1.0.0.ebuild
new file mode 100644
index 000000000000..6bc0182da5b4
--- /dev/null
+++ b/dev-python/python-pluginloader/python-pluginloader-1.0.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Library to manage python plugins/extensions"
+HOMEPAGE="https://github.com/magmax/python-pluginloader"
+SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]"