summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-31 09:52:08 +0100
committerSam James <sam@gentoo.org>2022-05-31 10:00:48 +0100
commit2f06a9a38e25e0cfe4e821bdeeb23b080abfb4c1 (patch)
treeac51c041f48f4e2bf5755af96d65b40f67e63da4 /dev-python/python-ptrace/python-ptrace-9999.ebuild
parentdev-python/websockets: x86 stable wrt bug #848687 (diff)
downloadgentoo-2f06a9a38e25e0cfe4e821bdeeb23b080abfb4c1.tar.gz
gentoo-2f06a9a38e25e0cfe4e821bdeeb23b080abfb4c1.tar.bz2
gentoo-2f06a9a38e25e0cfe4e821bdeeb23b080abfb4c1.zip
dev-python/python-ptrace: sync live; add Python 3.11
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/python-ptrace/python-ptrace-9999.ebuild')
-rw-r--r--dev-python/python-ptrace/python-ptrace-9999.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/dev-python/python-ptrace/python-ptrace-9999.ebuild b/dev-python/python-ptrace/python-ptrace-9999.ebuild
index c87c6168a30e..4822a8c9c7b5 100644
--- a/dev-python/python-ptrace/python-ptrace-9999.ebuild
+++ b/dev-python/python-ptrace/python-ptrace-9999.ebuild
@@ -3,18 +3,19 @@
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
inherit distutils-r1
DESCRIPTION="A Python binding of ptrace library"
HOMEPAGE="https://github.com/vstinner/python-ptrace"
-if [[ ${PV} == "9999" ]]; then
+if [[ ${PV} == 9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/vstinner/python-ptrace"
else
- SRC_URI="https://github.com/vstinner/python-ptrace/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/vstinner/python-ptrace/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
KEYWORDS="~amd64 ~x86"
fi