summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-29 07:26:51 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-29 07:49:16 +0200
commit7986cfcbbfbbcf05a8fdf3b58455ea7b479d391d (patch)
tree18cf536dd45077f43194be1d7f189e78be502f07 /dev-python/python-utils
parentdev-python/imageio: Bump to 2.30.0 (diff)
downloadgentoo-7986cfcbbfbbcf05a8fdf3b58455ea7b479d391d.tar.gz
gentoo-7986cfcbbfbbcf05a8fdf3b58455ea7b479d391d.tar.bz2
gentoo-7986cfcbbfbbcf05a8fdf3b58455ea7b479d391d.zip
dev-python/python-utils: Bump to 3.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-utils')
-rw-r--r--dev-python/python-utils/Manifest1
-rw-r--r--dev-python/python-utils/python-utils-3.6.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/python-utils/Manifest b/dev-python/python-utils/Manifest
index 719f9c00269d..31e2a045f9c4 100644
--- a/dev-python/python-utils/Manifest
+++ b/dev-python/python-utils/Manifest
@@ -1 +1,2 @@
DIST python-utils-3.5.2.tar.gz 26883 BLAKE2B 9532d8fecd8d57a9a9f50e2e7e67386e4c5922f4ec316851544147f6da82586bb01796bb3e3fc95c894a790c57711c983d8da9abc5edc5a722089a0d86d7fb61 SHA512 2e36bbb2e43591744c63ea972b7f361138694eb32510643ea88e8d757882379e3aec247c2fc4d5c67876939b71d564570a975700728c79f9db0cc4fcbc1605e7
+DIST python-utils-3.6.0.tar.gz 28488 BLAKE2B 0426943a631ad68afafdbe603d14a32e179e58f8c45ac98248096de40bb67243196ca4498e1b908a25e213301e26d42f3f2c175cfa282c18b1db8f15b14385e6 SHA512 2d26e9c37f42d525640b9573cd794acb93e44a01d817e4c9ccf2d07261581dd16a04f38d245f97efb01952476fbc312e1831b5b617659787cbaac38692853bdd
diff --git a/dev-python/python-utils/python-utils-3.6.0.ebuild b/dev-python/python-utils/python-utils-3.6.0.ebuild
new file mode 100644
index 000000000000..7ebf08d168c2
--- /dev/null
+++ b/dev-python/python-utils/python-utils-3.6.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Collection of small Python functions & classes"
+HOMEPAGE="
+ https://github.com/WoLpH/python-utils/
+ https://pypi.org/project/python-utils/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ docs
+ _python_utils_tests/test_logger.py
+ python_utils/loguru.py
+)
+
+python_prepare_all() {
+ sed -i -e '/--cov/d' -e '/--mypy/d' pytest.ini || die
+ distutils-r1_python_prepare_all
+}