summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-28 06:55:37 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-28 07:25:23 +0200
commit1e61d82c80eb4cf8842731057b65580acd0e4795 (patch)
tree8050883d5ce91080c22f94dd79148a4735527b64 /dev-python/pywayland
parentdev-python/easy-thumbnails: Bump to 2.9 (diff)
downloadgentoo-1e61d82c80eb4cf8842731057b65580acd0e4795.tar.gz
gentoo-1e61d82c80eb4cf8842731057b65580acd0e4795.tar.bz2
gentoo-1e61d82c80eb4cf8842731057b65580acd0e4795.zip
dev-python/pywayland: Bump to 0.4.18
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pywayland')
-rw-r--r--dev-python/pywayland/Manifest1
-rw-r--r--dev-python/pywayland/pywayland-0.4.18.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/pywayland/Manifest b/dev-python/pywayland/Manifest
index 52f42aeeed4d..51d5cc65e935 100644
--- a/dev-python/pywayland/Manifest
+++ b/dev-python/pywayland/Manifest
@@ -1 +1,2 @@
DIST pywayland-0.4.17.gh.tar.gz 61171 BLAKE2B f190107ab361ec9c0a568d22a104fa06a7e52a348a6226c30c2ae542b77e5b21b4a389ad745efb864b58cff9e77cb22ff43fd6614859cb138d398a84b99614a5 SHA512 9ca1e30b56f6d1447744451d15d84041d5ce6ce64811ca0e395822731f0c7cd1d8571f640b89771d8f5e9da1d82385734974e10e68ccecffc0f9600a83d2478b
+DIST pywayland-0.4.18.gh.tar.gz 62703 BLAKE2B d44858fb70b2a2d5e3a4f23766c1f00e255ea2fdbe3e5da47d2a114dfb6c4bd6951d971653db9727f54c3e697acb83d65446c08e670f32686520e35d6051e35c SHA512 cf46e3fed04a30eff4bb8293857fc9e874394bbd214b94cc2f73424e3c64d1c4a5df125189163e57d2b17017feb1e919588291e06c84acdc2e4479315b400932
diff --git a/dev-python/pywayland/pywayland-0.4.18.ebuild b/dev-python/pywayland/pywayland-0.4.18.ebuild
new file mode 100644
index 000000000000..2157e2935d60
--- /dev/null
+++ b/dev-python/pywayland/pywayland-0.4.18.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="Python bindings for the libwayland library"
+HOMEPAGE="
+ https://pywayland.readthedocs.io/en/latest/
+ https://github.com/flacjacket/pywayland
+ https://pypi.org/project/pywayland/
+"
+SRC_URI="
+ https://github.com/flacjacket/pywayland/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ dev-libs/wayland
+ $(python_gen_cond_dep '
+ dev-python/cffi[${PYTHON_USEDEP}]
+ ' 'python*')
+"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/wayland-protocols
+"
+BDEPEND="
+ dev-util/wayland-scanner
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Needed for tests (XDG_RUNTIME_DIR)
+ xdg_environment_reset
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # No die deliberately as sometimes it doesn't exist
+ rm -rf pywayland || die
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}