summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2016-11-20 17:19:34 +0100
committerDirkjan Ochtman <djc@gentoo.org>2016-11-20 17:19:51 +0100
commit2ff7a811dab79003a224c421d6bb1b0169eba5ba (patch)
tree2894b0a57b80c618f5ac1965dd0f2cfd7e2e06e5 /dev-python/pyyaml/pyyaml-3.11.ebuild
parentxfce-extra/xfce4-mpc-plugin: bump version and EAPI6 (diff)
downloadgentoo-2ff7a811dab79003a224c421d6bb1b0169eba5ba.tar.gz
gentoo-2ff7a811dab79003a224c421d6bb1b0169eba5ba.tar.bz2
gentoo-2ff7a811dab79003a224c421d6bb1b0169eba5ba.zip
dev-python/pyyaml: clean up insecure old version (see bug 544442)
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/pyyaml/pyyaml-3.11.ebuild')
-rw-r--r--dev-python/pyyaml/pyyaml-3.11.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-python/pyyaml/pyyaml-3.11.ebuild b/dev-python/pyyaml/pyyaml-3.11.ebuild
deleted file mode 100644
index 43301fc7d660..000000000000
--- a/dev-python/pyyaml/pyyaml-3.11.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{4,5} pypy pypy3 )
-
-inherit distutils-r1
-
-MY_P="PyYAML-${PV}"
-
-DESCRIPTION="YAML parser and emitter for Python"
-HOMEPAGE="http://pyyaml.org/wiki/PyYAML https://pypi.python.org/pypi/PyYAML"
-SRC_URI="http://pyyaml.org/download/${PN}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
-IUSE="examples libyaml"
-
-RDEPEND="libyaml? ( dev-libs/libyaml )"
-DEPEND="${RDEPEND}
- libyaml? ( $(python_gen_cond_dep 'dev-python/cython[${PYTHON_USEDEP}]' python2_7 'python3*') )"
-
-S="${WORKDIR}/${MY_P}"
-
-python_configure_all() {
- mydistutilsargs=( $(use_with libyaml) )
-}
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}
- fi
-}