summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-18 04:23:17 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-18 04:24:36 +0200
commitbdf5509e1cb50df6e0b272479977fc44451969d3 (patch)
treec00b20d0c2c5e8f76fdae6f915464ae20477900d /dev-python/rarfile
parentwww-client/chromium: add 117.0.5938.88 (diff)
downloadgentoo-bdf5509e1cb50df6e0b272479977fc44451969d3.tar.gz
gentoo-bdf5509e1cb50df6e0b272479977fc44451969d3.tar.bz2
gentoo-bdf5509e1cb50df6e0b272479977fc44451969d3.zip
dev-python/rarfile: Bump to 4.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/rarfile')
-rw-r--r--dev-python/rarfile/Manifest1
-rw-r--r--dev-python/rarfile/rarfile-4.1.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/rarfile/Manifest b/dev-python/rarfile/Manifest
index a37f413492e3..a65b190bd0cc 100644
--- a/dev-python/rarfile/Manifest
+++ b/dev-python/rarfile/Manifest
@@ -1 +1,2 @@
DIST rarfile-4.0.tar.gz 148026 BLAKE2B 331548d54dcc3d81c690cc383e36e3f00515999c72abb54060e0dbb34691bb7e06736318a33ec349492e27e561ed2f4ff4446cc5254e9f341f4633adaab878aa SHA512 05e15acd749564288d4f069970ac196344c33fd2710e918b84afe4c388aa364a17c63f86577037524336e3a022f6db2c8619f9b526f89e00753a8ab0d89263d4
+DIST rarfile-4.1.tar.gz 152826 BLAKE2B a64fbb036b33922ef99c73db3b32f3b08119ebc527d41751c2013ae05fb6d2f82523b818e7fe16983427094ab0baf15e93b356f1b19084fdfbec34cb2737780e SHA512 ca3ac26e02b8d7770c43fe70a06cf42b2183a34846d59c79d3478651e9d7ffc022fe7336be44b8df8fa6f0789bae055c1d057c21d87af78acccc43a927fd02e2
diff --git a/dev-python/rarfile/rarfile-4.1.ebuild b/dev-python/rarfile/rarfile-4.1.ebuild
new file mode 100644
index 000000000000..0e47d10edddc
--- /dev/null
+++ b/dev-python/rarfile/rarfile-4.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Module for RAR archive reading"
+HOMEPAGE="
+ https://github.com/markokr/rarfile/
+ https://pypi.org/project/rarfile/
+"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="+compressed test"
+REQUIRED_USE="test? ( compressed )"
+
+RDEPEND="
+ compressed? ( app-arch/unrar )
+"
+
+distutils_enable_tests pytest