summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-07 06:10:51 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-07 06:40:43 +0200
commit4022ab9896349602ce77c409a420f92f56782485 (patch)
tree6fb62e1975b432eb21de739740673a682e720f1b /dev-python/readthedocs-sphinx-ext
parentdev-python/pytest-check: Enable py3.12 (diff)
downloadgentoo-4022ab9896349602ce77c409a420f92f56782485.tar.gz
gentoo-4022ab9896349602ce77c409a420f92f56782485.tar.bz2
gentoo-4022ab9896349602ce77c409a420f92f56782485.zip
dev-python/readthedocs-sphinx-ext: Bump to 2.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/readthedocs-sphinx-ext')
-rw-r--r--dev-python/readthedocs-sphinx-ext/Manifest1
-rw-r--r--dev-python/readthedocs-sphinx-ext/readthedocs-sphinx-ext-2.2.1.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/readthedocs-sphinx-ext/Manifest b/dev-python/readthedocs-sphinx-ext/Manifest
index 6668a7cd5ea7..e3c39d586af2 100644
--- a/dev-python/readthedocs-sphinx-ext/Manifest
+++ b/dev-python/readthedocs-sphinx-ext/Manifest
@@ -1 +1,2 @@
DIST readthedocs-sphinx-ext-2.2.0.tar.gz 12721 BLAKE2B 3ac02a96a059e6d6b94af4318a5e816f8664e1164edb315d7540d1bfcce3b0edbbe9d567b0dc2931179cb309714175c64a3684b9d568551cc240ccbefc77a10a SHA512 8f7009a0716751de2fe2fed726aa08bb382d15ef6c4fb66e6c29537f985a92ab7cc137f81a4f6200e794cb7f495ebf561356194f57c694509b67e7686bef52c5
+DIST readthedocs-sphinx-ext-2.2.1.tar.gz 12644 BLAKE2B eb7b5f8d91dcf9f413cabe790537ed9179790c48e5778f026f07d442f4b446c6968b86c7e7eef4d548307ebd85ece8ff5a1fb3877ac4e3187ee8c53be86fc7dc SHA512 d2933228678549b7ab53bf7b8720eb23a5fcc05983dea56ab762906fc8a1445b2b94e0c12d647e18e6156fa1460a31ec0e7a7d7e4e8f5c46c5e39a9f35c382b9
diff --git a/dev-python/readthedocs-sphinx-ext/readthedocs-sphinx-ext-2.2.1.ebuild b/dev-python/readthedocs-sphinx-ext/readthedocs-sphinx-ext-2.2.1.ebuild
new file mode 100644
index 000000000000..00dffbb4b59c
--- /dev/null
+++ b/dev-python/readthedocs-sphinx-ext/readthedocs-sphinx-ext-2.2.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Code specific for Read the Docs and Sphinx"
+HOMEPAGE="
+ https://github.com/readthedocs/readthedocs-sphinx-ext/
+ https://pypi.org/project/readthedocs-sphinx-ext/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/jinja-2.9[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+
+# unittest should be sufficient but tests are very verbose, so pytest's
+# output capture is most welcome
+distutils_enable_tests pytest