summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-11 21:02:48 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-11 21:12:40 +0100
commit97cab8340626aa727b8e340da547eca19c7b5438 (patch)
tree82056fb132845549e4d44c2c179e7e66a8c378bf /dev-python/redis-py
parentdev-python/pysol_cards: Bump to 0.14.3 (diff)
downloadgentoo-97cab8340626aa727b8e340da547eca19c7b5438.tar.gz
gentoo-97cab8340626aa727b8e340da547eca19c7b5438.tar.bz2
gentoo-97cab8340626aa727b8e340da547eca19c7b5438.zip
dev-python/redis-py: Bump to 4.4.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/redis-py')
-rw-r--r--dev-python/redis-py/Manifest1
-rw-r--r--dev-python/redis-py/redis-py-4.4.2.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/dev-python/redis-py/Manifest b/dev-python/redis-py/Manifest
index db369ab5d50d..0177b85b54b4 100644
--- a/dev-python/redis-py/Manifest
+++ b/dev-python/redis-py/Manifest
@@ -1,2 +1,3 @@
DIST redis-py-4.4.0.gh.tar.gz 4637656 BLAKE2B 40b0909c27cefb399353cc2d1d82d7ad3d64e4b3e5ae001ffef9c198d0e65d906f5772a0ac33b599c7fb6ffc5dfad461bb4b9042c5c4fb23dfbfceb0a7facbc0 SHA512 8992f160de7817c48893f3a8588d5c0398dcfb91830a61b4218206adc88185acb102b072507d3064b4a7aade5c957267e5d0e6912510bb106eea834cf9250fab
DIST redis-py-4.4.1.gh.tar.gz 4733306 BLAKE2B b04a5925f87d8c1dbb06b30382f739d6bc39456b6b49be34701afcc1fecfca4783e60a451ddccdaff31f28c38b626e19607a57ebd600f7e28c63a4b62894f397 SHA512 0cec4b518bb56acee6a24ca62e7fdce054b4be764fcfaa860257d8de9f306d9d0f15a662354d7414a4a552475e2b49d97d97de05059310eead068a6269bc3038
+DIST redis-py-4.4.2.gh.tar.gz 4734100 BLAKE2B 8e23c9b81a19cbbead7d6dab682fc4efc75f0c29adb4df6b9bf17f6842b2823249036c67c133039a850504870a0f884275eb65f4e517f84211b51767d7a2ae15 SHA512 3303e87ccc9d4ea3afbb93bcc5e4dcc5bbb3a406878b07c5b8755f28f87cb7a0f9a0db989ec294c2cf42c4ec62f546b5d919a3cb3f11b4ba030e41d13ed2cfc8
diff --git a/dev-python/redis-py/redis-py-4.4.2.ebuild b/dev-python/redis-py/redis-py-4.4.2.ebuild
new file mode 100644
index 000000000000..cd0794a5536c
--- /dev/null
+++ b/dev-python/redis-py/redis-py-4.4.2.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python client for Redis key-value store"
+HOMEPAGE="
+ https://github.com/redis/redis-py/
+ https://pypi.org/project/redis/
+"
+SRC_URI="
+ https://github.com/redis/redis-py/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/async-timeout-4.0.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-db/redis
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Flaky test
+ tests/test_pubsub.py::TestPubSubDeadlock::test_pubsub_deadlock
+ # TODO
+ tests/test_commands.py::TestRedisCommands::test_acl_list
+ # redis-7 different return
+ tests/test_commands.py::TestRedisCommands::test_xautoclaim
+ )
+
+ # TODO: try to run more servers?
+ epytest -m "not redismod and not onlycluster and not replica and not ssl"
+}
+
+src_test() {
+ local redis_pid="${T}"/redis.pid
+ local redis_port=6379
+
+ if has_version ">=dev-db/redis-7"; then
+ local extra_conf="
+ enable-debug-command yes
+ enable-module-command yes
+ "
+ fi
+
+ # Spawn Redis itself for testing purposes
+ einfo "Spawning Redis"
+ einfo "NOTE: Port ${redis_port} must be free"
+ "${EPREFIX}"/usr/sbin/redis-server - <<- EOF || die "Unable to start redis server"
+ daemonize yes
+ pidfile ${redis_pid}
+ port ${redis_port}
+ bind 127.0.0.1 ::1
+ ${extra_conf}
+ EOF
+
+ # Run the tests
+ distutils-r1_src_test
+
+ # Clean up afterwards
+ kill "$(<"${redis_pid}")" || die
+}