summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/rednose
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/rednose')
-rw-r--r--dev-python/rednose/Manifest2
-rw-r--r--dev-python/rednose/metadata.xml13
-rw-r--r--dev-python/rednose/rednose-0.4.1.ebuild20
-rw-r--r--dev-python/rednose/rednose-0.4.3.ebuild25
4 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/rednose/Manifest b/dev-python/rednose/Manifest
new file mode 100644
index 000000000000..f063790f70f5
--- /dev/null
+++ b/dev-python/rednose/Manifest
@@ -0,0 +1,2 @@
+DIST rednose-0.4.1.tar.gz 5888 SHA256 82856136986ec6de3be4863ee2b7ecf0adbaaadb717a3e75fe517a6a5ac26825 SHA512 a9ff3bbbf35e6799a66728feb81f6d83b88ea9804bbebfc64d626d4bdb002c8e7a655027861b694fda15b9b8b24d7e3de2554f284e1683eafbf24eb24c4a192a WHIRLPOOL 0bbefdaf2426561c2712ddda5c77a1bd239e5e12139cebb4237a1c31d709cbf93548448d007a673824a8f4ea1e3c488eb270932c100ff396f3386f7d35cd559c
+DIST rednose-0.4.3.tar.gz 6046 SHA256 6ce5d40574c5569a23b2841678b0b14245ec5ea044a440bc6a1c20baec5464d7 SHA512 e0169599f251cd90a2906e489b870e7d10322a82253a3a814bc71aa257bea34bd5eb833b637dbae3128f8f37df79929aa4d6331e246654c83eb16118d637182a WHIRLPOOL 15937c7812111f780a6aab43b03ed9c8a395aa50ab0689886db0752d2866222be06d39d5491663e6322adc1906a897cc046cf33242e52a11429dff80a01ac37b
diff --git a/dev-python/rednose/metadata.xml b/dev-python/rednose/metadata.xml
new file mode 100644
index 000000000000..9316ec446967
--- /dev/null
+++ b/dev-python/rednose/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>alunduil@gentoo.org</email>
+ <name>Alex Brandt</name>
+ </maintainer>
+ <longdescription lang="en">
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">rednose</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/rednose/rednose-0.4.1.ebuild b/dev-python/rednose/rednose-0.4.1.ebuild
new file mode 100644
index 000000000000..935f71ab4e59
--- /dev/null
+++ b/dev-python/rednose/rednose-0.4.1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python{3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="coloured output for nosetests"
+HOMEPAGE="http://gfxmonk.net/dist/0install/rednose.xml"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=dev-python/python-termstyle-0.1.7[${PYTHON_USEDEP}]"
diff --git a/dev-python/rednose/rednose-0.4.3.ebuild b/dev-python/rednose/rednose-0.4.3.ebuild
new file mode 100644
index 000000000000..bd385a855d3c
--- /dev/null
+++ b/dev-python/rednose/rednose-0.4.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="coloured output for nosetests"
+HOMEPAGE="http://gfxmonk.net/dist/0install/rednose.xml"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ dev-python/colorama[${PYTHON_USEDEP}]
+ >=dev-python/python-termstyle-0.1.7[${PYTHON_USEDEP}]
+"