summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-02-10 02:47:38 +0000
committerSam James <sam@gentoo.org>2024-02-10 03:16:22 +0000
commit7c2cbe4c2526226f4f8a75f9587f1ee8078272e8 (patch)
tree2923469aad659b0fe769ef3b6ec533e8b4224971 /dev-python/regex
parentapp-vim/phpdocs: Stabilize 0.26-r2 ALLARCHES, #924182 (diff)
downloadgentoo-7c2cbe4c2526226f4f8a75f9587f1ee8078272e8.tar.gz
gentoo-7c2cbe4c2526226f4f8a75f9587f1ee8078272e8.tar.bz2
gentoo-7c2cbe4c2526226f4f8a75f9587f1ee8078272e8.zip
dev-python/regex: disable pypy3
It's unsupported upstream and on x86 at least, it ends up showing up precisely because of the UTF8-vs-ASCII strings representation problem. (See also https://github.com/mrabarnett/mrab-regex/issues/404 where the test issues got fixed but upstream made clear that it's unsupported and also can't really work properly.) Bug: https://github.com/mrabarnett/mrab-regex/issues/404 Bug: https://github.com/mrabarnett/mrab-regex/issues/521 Closes: https://bugs.gentoo.org/924136 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/regex')
-rw-r--r--dev-python/regex/regex-2023.12.25.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/dev-python/regex/regex-2023.12.25.ebuild b/dev-python/regex/regex-2023.12.25.ebuild
index c416999e19a9..2e070fd4b84d 100644
--- a/dev-python/regex/regex-2023.12.25.ebuild
+++ b/dev-python/regex/regex-2023.12.25.ebuild
@@ -5,7 +5,9 @@ EAPI=8
DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
+# pypy isn't supported upstream because of its UTF8 representation for strings
+# See https://github.com/mrabarnett/mrab-regex/issues/521#issuecomment-1936260187.
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 pypi