summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-10-11 09:03:40 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-10-11 11:24:29 +0300
commit1d72a5b3408c716a33520f4e2f8ee72eceb7979b (patch)
tree5376146ec750d4fa27b41722a19fc293bee36988 /dev-python/robot-detection
parentdev-python/colorspacious: mark ALLARCHES (diff)
downloadgentoo-1d72a5b3408c716a33520f4e2f8ee72eceb7979b.tar.gz
gentoo-1d72a5b3408c716a33520f4e2f8ee72eceb7979b.tar.bz2
gentoo-1d72a5b3408c716a33520f4e2f8ee72eceb7979b.zip
dev-python/robot-detection: enable py3.10, enable tests
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/robot-detection')
-rw-r--r--dev-python/robot-detection/robot-detection-0.4.0.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/dev-python/robot-detection/robot-detection-0.4.0.ebuild b/dev-python/robot-detection/robot-detection-0.4.0.ebuild
index a581ad559595..e43ccf957905 100644
--- a/dev-python/robot-detection/robot-detection-0.4.0.ebuild
+++ b/dev-python/robot-detection/robot-detection-0.4.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Module to detect if a given HTTP User Agent is a web crawler."
@@ -13,3 +13,5 @@ SRC_URI="https://github.com/rory/robot-detection/archive/v${PV}.tar.gz -> ${P}.t
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64"
+
+distutils_enable_tests unittest