summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-20 11:23:57 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-20 11:36:27 +0200
commit092193d8c6767d999e6f535d9d3b4933bb4d82d0 (patch)
treededdb64de678dfd486cfc45fd1b5760f54f2ed89 /dev-python/setuptools-git/setuptools-git-1.2-r2.ebuild
parentdev-python/regex: Remove python2 (diff)
downloadgentoo-092193d8c6767d999e6f535d9d3b4933bb4d82d0.tar.gz
gentoo-092193d8c6767d999e6f535d9d3b4933bb4d82d0.tar.bz2
gentoo-092193d8c6767d999e6f535d9d3b4933bb4d82d0.zip
dev-python/setuptools-git: Remove python2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/setuptools-git/setuptools-git-1.2-r2.ebuild')
-rw-r--r--dev-python/setuptools-git/setuptools-git-1.2-r2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/setuptools-git/setuptools-git-1.2-r2.ebuild b/dev-python/setuptools-git/setuptools-git-1.2-r2.ebuild
new file mode 100644
index 000000000000..d5dc2508e6b4
--- /dev/null
+++ b/dev-python/setuptools-git/setuptools-git-1.2-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Setuptools revision control system plugin for Git"
+HOMEPAGE="https://github.com/wichert/setuptools-git"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv s390 sparc x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-vcs/git"
+RDEPEND="${DEPEND}"
+
+python_test() {
+ git config --global user.name "test user" || die
+ git config --global user.email "test@email.com" || die
+ esetup.py test
+}