summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-19 00:46:06 +0000
committerSam James <sam@gentoo.org>2022-07-19 01:07:19 +0000
commit8099605cf67a3b110baddd10250a093563480571 (patch)
treed1b2fa402509225ce057936c33ce45eae3f5303c /dev-python/sh
parentdev-python/translate-toolkit: add 3.7.2 (diff)
downloadgentoo-8099605cf67a3b110baddd10250a093563480571.tar.gz
gentoo-8099605cf67a3b110baddd10250a093563480571.tar.bz2
gentoo-8099605cf67a3b110baddd10250a093563480571.zip
dev-python/sh: add 1.14.3
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/sh')
-rw-r--r--dev-python/sh/Manifest1
-rw-r--r--dev-python/sh/sh-1.14.3.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/sh/Manifest b/dev-python/sh/Manifest
index e58acd2905bc..5a74657fad05 100644
--- a/dev-python/sh/Manifest
+++ b/dev-python/sh/Manifest
@@ -1 +1,2 @@
DIST sh-1.14.2.tar.gz 63779 BLAKE2B adc9004334a53f3704e22c318df6b4f60fd9ca2d31f5a9601f84abfaf0fe2ded06938b165e10b1a977ed38fcad7d0fa08799f2f552fc2c6b9b4c2a6476477115 SHA512 b7917504ae85606e1986b681274077777ad3011639bfe933d4133c3ed16f930842e03b572caa396ca4d58f41fd5594bef776cc16c4b0fbd1242e57c6aad19e62
+DIST sh-1.14.3.tar.gz 62851 BLAKE2B e570b3d51bbabebc90a575aaa502dc448f5049caf7485763f7ca84bd30a1e19f37441e4217074cb75ee0094600d328b59693fffdb0647479478246e58c0f00a7 SHA512 f78b418a396b78b4d303846da222eedc7525dee8d200bf96d48054d91a82671d40e0f1f82eb406b16016752ff95c3b2360075974abc3a5a814b8cfe70528231a
diff --git a/dev-python/sh/sh-1.14.3.ebuild b/dev-python/sh/sh-1.14.3.ebuild
new file mode 100644
index 000000000000..233a8137076b
--- /dev/null
+++ b/dev-python/sh/sh-1.14.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python subprocess interface"
+HOMEPAGE="
+ https://github.com/amoffat/sh/
+ https://pypi.org/project/sh/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+PATCHES=(
+ "${FILESDIR}/sh-1.12.14-skip-unreliable-test.patch"
+ "${FILESDIR}/sh-1.14.0-skip-unreliable-test.patch"
+)
+
+python_test() {
+ "${EPYTHON}" test.py || die "Tests fail with ${EPYTHON}"
+}