summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-07-15 21:36:55 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-07-15 21:36:55 +0300
commitfd3ef30f64e9896909390f07a2a4ed4171dee5ae (patch)
treebdc02407e30179aa33ccb94fbf73d44b97f22042 /dev-python/simplegeneric/simplegeneric-0.8.1-r2.ebuild
parentdev-python/commentjson: enable py3.11 (diff)
downloadgentoo-fd3ef30f64e9896909390f07a2a4ed4171dee5ae.tar.gz
gentoo-fd3ef30f64e9896909390f07a2a4ed4171dee5ae.tar.bz2
gentoo-fd3ef30f64e9896909390f07a2a4ed4171dee5ae.zip
dev-python/simplegeneric: EAPI=8, PEP517
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/simplegeneric/simplegeneric-0.8.1-r2.ebuild')
-rw-r--r--dev-python/simplegeneric/simplegeneric-0.8.1-r2.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/simplegeneric/simplegeneric-0.8.1-r2.ebuild b/dev-python/simplegeneric/simplegeneric-0.8.1-r2.ebuild
new file mode 100644
index 000000000000..20ffd40907b1
--- /dev/null
+++ b/dev-python/simplegeneric/simplegeneric-0.8.1-r2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple generic functions for Python"
+HOMEPAGE="https://pypi.org/project/simplegeneric/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+BDEPEND="app-arch/unzip"
+
+distutils_enable_tests setup.py