summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-08-04 18:01:08 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-08-05 15:52:55 +0200
commitb4a5a49c49214af4c87e79ee9fd34d42dcdebad7 (patch)
treeeb3a6810ec8d75371a9949d3b1cef48087fe1cc4 /dev-python/simplejson/simplejson-3.16.0.ebuild
parentdev-python/jsonpointer: version bump. (diff)
downloadgentoo-b4a5a49c49214af4c87e79ee9fd34d42dcdebad7.tar.gz
gentoo-b4a5a49c49214af4c87e79ee9fd34d42dcdebad7.tar.bz2
gentoo-b4a5a49c49214af4c87e79ee9fd34d42dcdebad7.zip
dev-python/simplejson: version bump.
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-python/simplejson/simplejson-3.16.0.ebuild')
-rw-r--r--dev-python/simplejson/simplejson-3.16.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/simplejson/simplejson-3.16.0.ebuild b/dev-python/simplejson/simplejson-3.16.0.ebuild
new file mode 100644
index 000000000000..9004215f6c28
--- /dev/null
+++ b/dev-python/simplejson/simplejson-3.16.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy pypy3 )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Simple, fast, extensible JSON encoder/decoder for Python"
+HOMEPAGE="https://github.com/simplejson/simplejson https://pypi.org/project/simplejson/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( MIT AFL-2.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS=( README.rst CHANGES.txt )
+
+python_compile() {
+ if ! python_is_python3; then
+ local CFLAGS=${CFLAGS}
+ append-cflags -fno-strict-aliasing
+ fi
+ distutils-r1_python_compile
+}
+
+python_test() {
+ esetup.py test
+}