summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-07 05:37:11 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-07 06:18:57 +0200
commit88e94dfe94b8bf48cfabff25771b8a6e4fafcda4 (patch)
treeabb48aa5328b3a13f97e439cadebce2949b050e2 /dev-python/simplejson
parentdev-python/mypy: Bump to 1.2.0 (diff)
downloadgentoo-88e94dfe94b8bf48cfabff25771b8a6e4fafcda4.tar.gz
gentoo-88e94dfe94b8bf48cfabff25771b8a6e4fafcda4.tar.bz2
gentoo-88e94dfe94b8bf48cfabff25771b8a6e4fafcda4.zip
dev-python/simplejson: Bump to 3.19.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/simplejson')
-rw-r--r--dev-python/simplejson/Manifest1
-rw-r--r--dev-python/simplejson/simplejson-3.19.1.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/simplejson/Manifest b/dev-python/simplejson/Manifest
index 3edfa3904273..d70d013eebc9 100644
--- a/dev-python/simplejson/Manifest
+++ b/dev-python/simplejson/Manifest
@@ -1,2 +1,3 @@
DIST simplejson-3.18.3.gh.tar.gz 81540 BLAKE2B bf6a162499b28a362638e19735f668571f88943ae396fb7f813d51ab0684caa8cb996a35deaf1d68adee2a812d685058e9e80d6f6e66604bbb7c704051b0b37f SHA512 54223e08775ab6277722342084bf56684588dd9dda574428cb73b791d37d0b74decef6082268c0389cc4586a534a19e62ec5738fa9ffffaee63f68e27fb465c8
DIST simplejson-3.18.4.tar.gz 83721 BLAKE2B fb9ea04402ba740a445751ff2be2f5f5c826e20f38289dcf9aa9c8abbaba4b59bf906c3378317818c77bcfa6ccc3fe76608651eac660683eeac61f5750099e3d SHA512 6335389eb620c96d5c537cd335e20d4f112b86c0c463ceed4d8fa36c27bab8b00386b7995e40070bda5eed1fe5883a462579c7d09bdbc828c39537282669d0e4
+DIST simplejson-3.19.1.tar.gz 85207 BLAKE2B 4c3d1d5de4292404e44977777332fe57327ece1afcd9890b605d52a248764612da351b7c5afb36d4e1cdcb530f07b99b8d971124899b86e4b2f4005a66afcbb5 SHA512 a2239a932f43abe59da84fc3ba95eeaa6a720c929da79d8f4447603b8c770403c9cba0f008a66c20c5c8aa3255891b687336eef1db071171a2c8435563bbb1bd
diff --git a/dev-python/simplejson/simplejson-3.19.1.ebuild b/dev-python/simplejson/simplejson-3.19.1.ebuild
new file mode 100644
index 000000000000..8afcfa37c4ea
--- /dev/null
+++ b/dev-python/simplejson/simplejson-3.19.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Simple, fast, extensible JSON encoder/decoder for Python"
+HOMEPAGE="
+ https://github.com/simplejson/simplejson/
+ https://pypi.org/project/simplejson/
+"
+
+LICENSE="|| ( MIT AFL-2.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="+native-extensions"
+
+DOCS=( README.rst CHANGES.txt )
+
+distutils_enable_tests unittest
+
+src_configure() {
+ export DISABLE_SPEEDUPS=$(usex native-extensions 0 1)
+ use native-extensions && export REQUIRE_SPEEDUPS=1
+}
+
+python_test() {
+ cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
+ eunittest
+}