summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-03-29 11:00:41 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-03-29 11:49:19 -0400
commit08d2abc5b57f8ff9d196e311c6adb09300ec1253 (patch)
tree31d42b7b36e72bc4dfc922c1a42507a6a1b17233 /dev-python/sip
parentsys-apps/busybox: sync live version (diff)
downloadgentoo-08d2abc5b57f8ff9d196e311c6adb09300ec1253.tar.gz
gentoo-08d2abc5b57f8ff9d196e311c6adb09300ec1253.tar.bz2
gentoo-08d2abc5b57f8ff9d196e311c6adb09300ec1253.zip
dev-python/sip: enable tests
The (newly available) GH repo does not seem to have anything to generate version.py (which would rather not risk getting wrong), and also lacks the Changelog and some other generated docs files. Then pypi's tarball lack tests. Bit wasteful but both tarballs are small and combining seems safe (verified that no changes to installed files, so skipping a safety revbump to ~testing). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-python/sip')
-rw-r--r--dev-python/sip/Manifest1
-rw-r--r--dev-python/sip/sip-6.8.3.ebuild12
2 files changed, 9 insertions, 4 deletions
diff --git a/dev-python/sip/Manifest b/dev-python/sip/Manifest
index e3cd2d269ac7..7ee71215d482 100644
--- a/dev-python/sip/Manifest
+++ b/dev-python/sip/Manifest
@@ -1 +1,2 @@
+DIST sip-6.8.3.gh.tar.gz 585528 BLAKE2B 2a58edba0f7ca9da02399df9fe71f152ef8446c38886ca2a21c00ef3ac65e0a82493a6047120d6f786e5b26f974c9cac24a329f1a52d9c47f9669afe2f0789b4 SHA512 6ff5fa59a55d71a3303553d2c53879fc9ccc01b9db34da149a7b81e252613327c7390c5a2edeaec03381dbc36ed38aa4ce44d69560c277ecc3875a57e7d75a60
DIST sip-6.8.3.tar.gz 987656 BLAKE2B 57cc4010aae64eec7e0f338d9653463c7381b639aa8efca978a3f3296550a37b3a09b52933a2c2cd354a65155841952d7ca045b0b774945a382c29a8d597951e SHA512 8a0ff1c16ead4c2b1c53963a015fb3d149362f649eeec2523e6b243945493f28f5ecf29aabbf5cee5f7909ded40d64a1f469d2d0c1b3c33244e6213ab23ec733
diff --git a/dev-python/sip/sip-6.8.3.ebuild b/dev-python/sip/sip-6.8.3.ebuild
index aaed5118beb9..5f9ffe71e07e 100644
--- a/dev-python/sip/sip-6.8.3.ebuild
+++ b/dev-python/sip/sip-6.8.3.ebuild
@@ -5,13 +5,16 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..12} )
-
inherit distutils-r1 pypi
DESCRIPTION="Python bindings generator for C/C++ libraries"
-HOMEPAGE="
- https://github.com/Python-SIP/sip/
- https://pypi.org/project/sip/
+HOMEPAGE="https://github.com/Python-SIP/sip/"
+# gh does not include a way to generate some files, so combine with pypi
+SRC_URI+="
+ test? (
+ https://github.com/Python-SIP/sip/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ )
"
LICENSE="|| ( GPL-2 GPL-3 SIP )"
@@ -25,3 +28,4 @@ RDEPEND="
"
distutils_enable_sphinx doc --no-autodoc
+distutils_enable_tests pytest