summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-17 10:03:38 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-17 10:14:56 +0100
commit74402352c6e28241cee03357a6d5993b9e5e3765 (patch)
tree05cf1128226a429b7e026b7fefd7f44e9969bc6f /dev-python/sniffio
parentdev-python/python-socks: Bump to 2.0.1 (diff)
downloadgentoo-74402352c6e28241cee03357a6d5993b9e5e3765.tar.gz
gentoo-74402352c6e28241cee03357a6d5993b9e5e3765.tar.bz2
gentoo-74402352c6e28241cee03357a6d5993b9e5e3765.zip
dev-python/sniffio: Enable pypy3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sniffio')
-rw-r--r--dev-python/sniffio/sniffio-1.2.0.ebuild14
1 files changed, 5 insertions, 9 deletions
diff --git a/dev-python/sniffio/sniffio-1.2.0.ebuild b/dev-python/sniffio/sniffio-1.2.0.ebuild
index f6f3ddbd3664..13064b3ad091 100644
--- a/dev-python/sniffio/sniffio-1.2.0.ebuild
+++ b/dev-python/sniffio/sniffio-1.2.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Sniff out which async library your code is running under"
@@ -20,11 +20,7 @@ KEYWORDS="amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv sparc x86"
distutils_enable_tests pytest
-python_test() {
- local deselect=(
- # curio is not packaged
- sniffio/_tests/test_sniffio.py::test_curio
- )
-
- epytest ${deselect[@]/#/--deselect }
-}
+EPYTEST_DESELECT=(
+ # curio is not packaged
+ sniffio/_tests/test_sniffio.py::test_curio
+)