summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-05 16:26:16 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-05 19:05:41 +0200
commitec9c2f5f1a45f75d1bf9db46ead36de4df98a920 (patch)
tree8f2dd6bc275037078e214e2ebf1bd0e9920f27b0 /dev-python/sortedcontainers
parentdev-python/mock: Enable python3.10 (diff)
downloadgentoo-ec9c2f5f1a45f75d1bf9db46ead36de4df98a920.tar.gz
gentoo-ec9c2f5f1a45f75d1bf9db46ead36de4df98a920.tar.bz2
gentoo-ec9c2f5f1a45f75d1bf9db46ead36de4df98a920.zip
dev-python/sortedcontainers: Enable python3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sortedcontainers')
-rw-r--r--dev-python/sortedcontainers/sortedcontainers-2.3.0.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-python/sortedcontainers/sortedcontainers-2.3.0.ebuild b/dev-python/sortedcontainers/sortedcontainers-2.3.0.ebuild
index 10cc79be2368..8f7ca5dd0de0 100644
--- a/dev-python/sortedcontainers/sortedcontainers-2.3.0.ebuild
+++ b/dev-python/sortedcontainers/sortedcontainers-2.3.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} pypy3 )
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
inherit distutils-r1
@@ -24,5 +24,5 @@ distutils_enable_tests pytest
python_test() {
local -x PYTHONPATH=.
- pytest -vv --ignore docs/conf.py || die "Tests fail with ${EPYTHON}"
+ epytest --ignore docs/conf.py
}