summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-09-14 11:46:37 +0200
committerLouis Sautier <sbraz@gentoo.org>2020-09-14 12:20:00 +0200
commitc534153630f733a6962380de1eeedaa402ceb0e4 (patch)
tree2616474d3c10d767105ffd57886ca2edb8ebec99 /dev-python/sphinx-notfound-page/sphinx-notfound-page-0.5.ebuild
parentdev-python/autopep8: Sync live ebuild (diff)
downloadgentoo-c534153630f733a6962380de1eeedaa402ceb0e4.tar.gz
gentoo-c534153630f733a6962380de1eeedaa402ceb0e4.tar.bz2
gentoo-c534153630f733a6962380de1eeedaa402ceb0e4.zip
dev-python/sphinx-notfound-page: v0.5, Py3.8+3.9, tests, fix deps
Package-Manager: Portage-3.0.6, Repoman-3.0.1 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/sphinx-notfound-page/sphinx-notfound-page-0.5.ebuild')
-rw-r--r--dev-python/sphinx-notfound-page/sphinx-notfound-page-0.5.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/sphinx-notfound-page/sphinx-notfound-page-0.5.ebuild b/dev-python/sphinx-notfound-page/sphinx-notfound-page-0.5.ebuild
new file mode 100644
index 000000000000..6fef53b3f911
--- /dev/null
+++ b/dev-python/sphinx-notfound-page/sphinx-notfound-page-0.5.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Create a custom 404 page with absolute URLs hardcoded."
+HOMEPAGE="https://sphinx-notfound-page.readthedocs.io/"
+# PyPI tarballs lack tests
+# https://github.com/readthedocs/sphinx-notfound-page/pull/110
+SRC_URI="https://github.com/readthedocs/sphinx-notfound-page/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~x64-macos"
+
+RDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest