summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-17 07:41:58 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-17 09:34:48 +0200
commite004a44e0c788f913debaaba01c925b6c38934de (patch)
tree5918da76f2a09ba3020261069d3c4508bfb90bf6 /dev-python/sqlalchemy
parentdev-python/hypothesis: Bump to 6.81.2 (diff)
downloadgentoo-e004a44e0c788f913debaaba01c925b6c38934de.tar.gz
gentoo-e004a44e0c788f913debaaba01c925b6c38934de.tar.bz2
gentoo-e004a44e0c788f913debaaba01c925b6c38934de.zip
dev-python/sqlalchemy: Bump to 2.0.19
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sqlalchemy')
-rw-r--r--dev-python/sqlalchemy/Manifest1
-rw-r--r--dev-python/sqlalchemy/sqlalchemy-2.0.19.ebuild120
2 files changed, 121 insertions, 0 deletions
diff --git a/dev-python/sqlalchemy/Manifest b/dev-python/sqlalchemy/Manifest
index d45cb24b3312..56ba0ef9404c 100644
--- a/dev-python/sqlalchemy/Manifest
+++ b/dev-python/sqlalchemy/Manifest
@@ -6,3 +6,4 @@ DIST SQLAlchemy-2.0.15.tar.gz 9296612 BLAKE2B 45abdb9010b854e52762d9c84a471e92ec
DIST SQLAlchemy-2.0.16.tar.gz 9381438 BLAKE2B 8999ab045d799c43de1b386d594022a8015fba4d69b3c910622e34b83ea7514b9cb97ab4f65997813eca058eff2a285ecc6cdd09396edf27a216fe412387ba7b SHA512 f0d5287ba6cee97316d6de7cf1c893dd749459d912872d903833abf905b6c282fa477910fa5eb11b5ba803314e16c3f1a9ac6b7639573c4c44ff921ea56132da
DIST SQLAlchemy-2.0.17.tar.gz 9394733 BLAKE2B d6237b4bc5f7c3e0ba615161ee112f520b87102d7f498ab0db9bf30287fc131111c04910f1d00b059b277be5626af62f64f01101486c2eb31258c75ed4411db6 SHA512 be45d1283fc446c7ed886d87d9225711b8f0125e8de6961b365930515246e94c3943fd85d078056c942508a9785731bf280519e04b0c00d936e93d3b9b6c137f
DIST SQLAlchemy-2.0.18.tar.gz 9417280 BLAKE2B 0f67e993c91cbf5fb2b5c9481e531830c24f69cb583ab0045b844048e92e57c2a9d826f098b792c0dfc807236fcb422fb800d201473e75fafc1190282d7c27f1 SHA512 4665994e4dc07b5ba0e0549cf80c0cc542c87609c74dce1e5523d4d6bfd5e1be5c7b62562e151c864a2e2a836cceb8374e804871937c738e54a1aa17297732ce
+DIST SQLAlchemy-2.0.19.tar.gz 9425046 BLAKE2B 258e273a1c9ec5584293d08b0cc9de8ab4076e61bbae2b914950d38e4627591e1c57250f5c28625e5d84d3db360992952a22644992ed5244d36d616f20487fc5 SHA512 d82834f4f55c2298ff16401f34326845360c58e6ba6a2e22cda92219c0fb40938d404315027f4e9f392bc57fe45808ea192f99b747e073a40a9713f8d498b22a
diff --git a/dev-python/sqlalchemy/sqlalchemy-2.0.19.ebuild b/dev-python/sqlalchemy/sqlalchemy-2.0.19.ebuild
new file mode 100644
index 000000000000..8a0e1b74df5a
--- /dev/null
+++ b/dev-python/sqlalchemy/sqlalchemy-2.0.19.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+PYTHON_REQ_USE="sqlite?"
+
+inherit distutils-r1 optfeature pypi
+
+MY_PN="SQLAlchemy"
+DESCRIPTION="Python SQL toolkit and Object Relational Mapper"
+HOMEPAGE="
+ https://www.sqlalchemy.org/
+ https://pypi.org/project/SQLAlchemy/
+ https://github.com/sqlalchemy/sqlalchemy/
+"
+SRC_URI="$(pypi_sdist_url --no-normalize "${MY_PN}")"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="examples +sqlite test"
+
+RDEPEND="
+ >=dev-python/typing-extensions-4.2.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_impl_dep sqlite)
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/greenlet/d' setup.cfg || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ test/ext/mypy/test_mypy_plugin_py3k.py
+ test/typing/test_mypy.py
+ # hardcode call counts specific to Python versions
+ test/aaa_profiling
+ )
+ local EPYTEST_DESELECT=(
+ # warning tests are unreliable
+ test/base/test_warnings.py
+ # TODO
+ test/orm/test_versioning.py::ServerVersioningTest_sqlite+pysqlite_3_40_1::test_sql_expr_w_mods_bump
+ test/sql/test_resultset.py::CursorResultTest_sqlite+pysqlite_3_41_0::test_pickle_rows_other_process
+ )
+ local sqlite_version=$(sqlite3 --version | cut -d' ' -f1)
+ [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
+ test/ext/test_associationproxy.py::ProxyHybridTest::test_msg_fails_on_cls_access
+ test/ext/test_associationproxy.py::DictOfTupleUpdateTest::test_update_multi_elem_varg
+ test/ext/test_associationproxy.py::DictOfTupleUpdateTest::test_update_one_elem_varg
+ test/engine/test_pool.py::QueuePoolTest::test_recycle_pool_no_race
+ test/engine/test_processors.py::PyDateProcessorTest::test_date_invalid_string
+ test/engine/test_processors.py::PyDateProcessorTest::test_datetime_invalid_string
+ test/engine/test_processors.py::PyDateProcessorTest::test_time_invalid_string
+ "test/dialect/test_sqlite.py::TestTypes_sqlite+pysqlite_${sqlite_version//./_}::test_cant_parse_datetime_message"
+ "test/dialect/test_suite.py::ReturningGuardsTest_sqlite+pysqlite_${sqlite_version//./_}"::test_{delete,insert,update}_single
+ test/base/test_utils.py::ImmutableDictTest::test_pep584
+ )
+ [[ ${EPYTHON} == python3.12 ]] && EPYTEST_DESELECT+=(
+ # see https://github.com/sqlalchemy/sqlalchemy/issues/9819
+ test/base/test_result.py::ResultTupleTest::test_slices_arent_in_mappings
+ )
+ if ! has_version "dev-python/greenlet[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ test/ext/asyncio/test_engine_py3k.py::TextSyncDBAPI::test_sync_driver_execution
+ test/ext/asyncio/test_engine_py3k.py::TextSyncDBAPI::test_sync_driver_run_sync
+ "test/engine/test_pool.py::PoolEventsTest::test_checkin_event_gc[False-True]"
+ "test/engine/test_pool.py::PoolEventsTest::test_checkin_event_gc[True-True]"
+ "test/engine/test_pool.py::PoolEventsTest::test_checkin_event_gc[has_terminate-is_asyncio]"
+ "test/engine/test_pool.py::PoolEventsTest::test_checkin_event_gc[not_has_terminate-is_asyncio]"
+ "test/engine/test_pool.py::QueuePoolTest::test_userspace_disconnectionerror_weakref_finalizer[True-_exclusions0]"
+ "test/engine/test_pool.py::QueuePoolTest::test_userspace_disconnectionerror_weakref_finalizer[True]"
+ )
+ fi
+
+ # upstream's test suite is horribly hacky; it relies on disabling
+ # the warnings plugin and turning warnings into errors; this also
+ # means that any DeprecationWarnings from third-party plugins cause
+ # everything to explode
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=
+ # upstream automagically depends on xdist when it is importable
+ # note that we can't use xdist because it causes nodes to randomly
+ # crash on init
+ if has_version "dev-python/pytest-xdist[${PYTHON_USEDEP}]"; then
+ PYTEST_PLUGINS+=xdist.plugin
+ fi
+ epytest
+}
+
+python_install_all() {
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ dodoc -r examples
+ fi
+
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ optfeature "asyncio support" dev-python/greenlet
+ optfeature "MySQL support" \
+ dev-python/mysqlclient \
+ dev-python/pymysql \
+ dev-python/mysql-connector-python
+ optfeature "postgresql support" dev-python/psycopg:2
+}