summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2022-05-26 10:51:05 -0500
committerBen Kohler <bkohler@gentoo.org>2022-05-26 10:51:15 -0500
commitf95d99f721251ca74b82c9fa25f5092736374cae (patch)
treed22d48c59b0696c8e2f7bf39a4036ad753262b22 /dev-python/stapler
parentwww-client/links: drop 2.25-r3, 2.26 (diff)
downloadgentoo-f95d99f721251ca74b82c9fa25f5092736374cae.tar.gz
gentoo-f95d99f721251ca74b82c9fa25f5092736374cae.tar.bz2
gentoo-f95d99f721251ca74b82c9fa25f5092736374cae.zip
dev-python/stapler: add 1.0.0_p20220330, with PEP517 conversion
Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'dev-python/stapler')
-rw-r--r--dev-python/stapler/Manifest1
-rw-r--r--dev-python/stapler/stapler-1.0.0_p20220330.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/stapler/Manifest b/dev-python/stapler/Manifest
index b2db9557c9dd..6bede0683dca 100644
--- a/dev-python/stapler/Manifest
+++ b/dev-python/stapler/Manifest
@@ -1 +1,2 @@
DIST stapler-1.0.0_p20200531.tar.gz 42840 BLAKE2B bfa909e25dfd65101321e153f5129d28bbb360845d6a3622c53ec3921610b9987a8e5c85c4428ee1cd196c0ee42b5a2eefdca7c4a75be223867fad4d830b148a SHA512 7c5f76240f1dff67eae3eb25d29087c7bbff3aace65030d10836f60769798d653b30acb6cc89355ba1eb590dbfc3236cb4ae95c02db6e779ad474781a17bdbc8
+DIST stapler-1.0.0_p20220330.tar.gz 43659 BLAKE2B 10c24868d51086b37dd2d517aa84e3c3fc0b6becc7a29ebf496646bdd65494eb0c43488f725241d7bd7b3083ce5703538db3e05de9976a2e5029731fc2e645d2 SHA512 acd2dfec0dfab46b2cf6b440cba6c0db5399be2ba2194ca12530c311c6c5a8028614164af45b850061e7d22cbec33458ceff7757f1b104c722228dc2d02cae0a
diff --git a/dev-python/stapler/stapler-1.0.0_p20220330.ebuild b/dev-python/stapler/stapler-1.0.0_p20220330.ebuild
new file mode 100644
index 000000000000..b1ac532be99b
--- /dev/null
+++ b/dev-python/stapler/stapler-1.0.0_p20220330.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=poetry
+
+inherit distutils-r1
+
+COMMIT="382f1edc62296e071093a5419811a2fca9d78d93"
+
+DESCRIPTION="Suite of tools for PDF files manipulation written in Python"
+HOMEPAGE="https://github.com/hellerbarde/stapler"
+SRC_URI="https://github.com/hellerbarde/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/PyPDF2[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest