summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-22 09:08:47 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-22 09:08:47 +0200
commit1db30408da00a2ee671128287eac6bc1ee34966c (patch)
tree97baf83d2017684cceb0caad27ec6c56bbf370b7 /dev-python/statsmodels
parentdev-python/spyder: Remove redundant versions (diff)
downloadgentoo-1db30408da00a2ee671128287eac6bc1ee34966c.tar.gz
gentoo-1db30408da00a2ee671128287eac6bc1ee34966c.tar.bz2
gentoo-1db30408da00a2ee671128287eac6bc1ee34966c.zip
dev-python/statsmodels: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/statsmodels')
-rw-r--r--dev-python/statsmodels/Manifest1
-rw-r--r--dev-python/statsmodels/statsmodels-0.10.2.ebuild72
2 files changed, 0 insertions, 73 deletions
diff --git a/dev-python/statsmodels/Manifest b/dev-python/statsmodels/Manifest
index 7fcf0bc04fbb..dba98937e083 100644
--- a/dev-python/statsmodels/Manifest
+++ b/dev-python/statsmodels/Manifest
@@ -1,2 +1 @@
-DIST statsmodels-0.10.2.tar.gz 14065612 BLAKE2B 0df1268de5e4108b3cc541df87a5b9d2321bd3062d4daf1cc1aa62ab08ee777bace2f10bdfb51f088a66f15287c62cf851b3f43efa7eb1227e71c06632e80d55 SHA512 bd1c0784b0b17a3ca69fef5848f5eea8dcf76b1943599a5e5c285e45b7fcc7e44c0e388f007913d420ff6f3cb66a653d1c43e6e8addef534ff5572fa69ffb54a
DIST statsmodels-0.11.1.tar.gz 15381516 BLAKE2B a40cf9138edd8a9a6707a550d9885e0610f9bc666fcd73a60bd11ade6dcfa806ecd912a725cf2a13902e92f31af2c3e82f244280f70586bb3359dc8fc2842508 SHA512 54afe55a23b431154c159f44d284aa093f3368988f0695c0f3fbb206046cdfb171ab2ba51ce94285d567b8536141f93a1ef404b5f7222f1e61264baf0541926d
diff --git a/dev-python/statsmodels/statsmodels-0.10.2.ebuild b/dev-python/statsmodels/statsmodels-0.10.2.ebuild
deleted file mode 100644
index dcb371cf4e57..000000000000
--- a/dev-python/statsmodels/statsmodels-0.10.2.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1 eutils
-
-DESCRIPTION="Statistical computations and models for use with SciPy"
-HOMEPAGE="https://www.statsmodels.org/stable/index.html"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/numpy[${PYTHON_USEDEP}]
- >=dev-python/pandas-0.23.0[${PYTHON_USEDEP}]
- dev-python/patsy[${PYTHON_USEDEP}]
- sci-libs/scipy[${PYTHON_USEDEP}]
-"
-BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- doc? (
- dev-python/ipykernel[${PYTHON_USEDEP}]
- dev-python/jupyter_client[${PYTHON_USEDEP}]
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/nbconvert[${PYTHON_USEDEP}]
- dev-python/nbformat[${PYTHON_USEDEP}]
- dev-python/numpydoc[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- )
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- )
-"
-
-python_prepare_all() {
- # Prevent un-needed d'loading
- sed -e "/sphinx.ext.intersphinx/d" -i docs/source/conf.py || die
- export VARTEXFONTS="${T}"/fonts
- export MPLCONFIGDIR="${T}"
- echo "backend : Agg" > "${MPLCONFIGDIR}"/matplotlibrc || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && esetup.py build_sphinx -b html --build-dir=docs/build
-}
-
-python_test() {
- cd "${BUILD_DIR}" || die
- ${EPYTHON} -c 'import statsmodels; statsmodels.test()' || die
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/build/html/. )
- if use examples; then
- docompress -x /usr/share/doc/${PF}/examples
- dodoc -r examples
- fi
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- optfeature "Plotting functionality" "dev-python/matplotlib"
-}