summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-10 08:50:05 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-10 09:06:09 +0200
commitf1947adb7c09a09391a8cad3d548cc63affc2a12 (patch)
tree573fd7657a81408225843bbe1916ec7553669cfd /dev-python/tekore
parentdev-python/tekore: Remove old (diff)
downloadgentoo-f1947adb7c09a09391a8cad3d548cc63affc2a12.tar.gz
gentoo-f1947adb7c09a09391a8cad3d548cc63affc2a12.tar.bz2
gentoo-f1947adb7c09a09391a8cad3d548cc63affc2a12.zip
dev-python/tekore: Bump to 5.5.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tekore')
-rw-r--r--dev-python/tekore/Manifest1
-rw-r--r--dev-python/tekore/tekore-5.5.1.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/tekore/Manifest b/dev-python/tekore/Manifest
index cc5e7cd38b48..315f197e2065 100644
--- a/dev-python/tekore/Manifest
+++ b/dev-python/tekore/Manifest
@@ -1 +1,2 @@
DIST tekore-5.5.0.tar.gz 270803 BLAKE2B 37b7410e701b67917af76bac07499a9a910916eed8e9dd87e394e420309ed9a3094a6cf600182db084523eeb6942c6a9ebfdda108f8b1f5ef848be4a02a32f6a SHA512 b78eea1fafd27bbeb230f9b697783e3b8cd1aebc93633f168dba07d94bee80ddefedf792ea7870b258757559256424db74d21f3e14201e8c3df801fac4d12067
+DIST tekore-5.5.1.tar.gz 270328 BLAKE2B 44a03289ff908b97da7ef089513156b00b8858d99172139981ce6b618074a628796f3f965a1180f7ee0cb2c23e5c97fd0f7ce1ea9da3d6352102e2da3406b1cf SHA512 aec3eddadfd27098a4608a193750bb521d1e4c5c786c09b98e4295ed167dc3ac88b9382528778513a8b2143153950a02b7cbbdbbae1775259ab29c3df17abe05
diff --git a/dev-python/tekore/tekore-5.5.1.ebuild b/dev-python/tekore/tekore-5.5.1.ebuild
new file mode 100644
index 000000000000..1f28340fe779
--- /dev/null
+++ b/dev-python/tekore/tekore-5.5.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Spotify Web API client"
+HOMEPAGE="
+ https://tekore.readthedocs.io/
+ https://github.com/felix-hilden/tekore/
+ https://pypi.org/project/tekore/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ dev-python/httpx[${PYTHON_USEDEP}]
+ >=dev-python/pydantic-1.8[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ >=dev-python/pydantic-2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.17[${PYTHON_USEDEP}]
+ dev-python/pytest-httpx[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+# TODO: package sphinx_codeautolink
+# distutils_enable_sphinx docs/src \
+# dev-python/sphinx-rtd-theme \
+# dev-python/sphinx-tabs \
+# dev-python/sphinx-autodoc-typehints
+
+EPYTEST_DESELECT=(
+ # Internet
+ tests/auth/expiring.py::TestCredentialsOnline::test_bad_arguments_raises_error
+)
+
+src_prepare() {
+ # unpin dependencies
+ sed -i -e 's:,<[0-9.]*::' pyproject.toml || die
+
+ distutils-r1_src_prepare
+}