summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-12 12:53:52 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-12 13:18:41 +0200
commit87a13293ae489f36d15032ff64eebc90cb70f529 (patch)
treeb629dfd0f45aeba8679bff15ed63dea4828f9ee9 /dev-python/tifffile
parentdev-python/tifffile: Remove old (diff)
downloadgentoo-87a13293ae489f36d15032ff64eebc90cb70f529.tar.gz
gentoo-87a13293ae489f36d15032ff64eebc90cb70f529.tar.bz2
gentoo-87a13293ae489f36d15032ff64eebc90cb70f529.zip
dev-python/tifffile: Bump to 2022.10.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tifffile')
-rw-r--r--dev-python/tifffile/Manifest1
-rw-r--r--dev-python/tifffile/tifffile-2022.10.10.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/tifffile/Manifest b/dev-python/tifffile/Manifest
index 2c520151d517..a61bfb9badd5 100644
--- a/dev-python/tifffile/Manifest
+++ b/dev-python/tifffile/Manifest
@@ -1 +1,2 @@
+DIST tifffile-2022.10.10.gh.tar.gz 315965 BLAKE2B 9f1d5c37062fd2fd2c30411b479d77977d387e4df19ae795fba085179f7ad0e3dfafa6068ccc895586f59a2437a1203748b3e1bbeb0f4a2d433728c2e79fc47a SHA512 7ccd6b4b802e63ca2646ea4f716fb16f02a091042c02d200c7a6756dc06a60d7d165aa5fefc63db954e60dcaf6bf8626349de7e4b836394b70df7ee71ec28790
DIST tifffile-2022.8.12.gh.tar.gz 312278 BLAKE2B ac48e3071f94855762f40173ce422fca5a980a88e20f0ea232a4d9ffedf0918c21b452ec168a1fb1481e2cd54fd4ce38a5b971bb7987c098fa1bf0a6aeedbf94 SHA512 35d7e7387bb2c7bcf88e8dac12e13c836a009f9344c9ae0cb0ca80184a42e6018744f09bdaa0d12c436b0561dcd96b97b2e6ca8106c512912b1eae813c5c3902
diff --git a/dev-python/tifffile/tifffile-2022.10.10.ebuild b/dev-python/tifffile/tifffile-2022.10.10.ebuild
new file mode 100644
index 000000000000..dcc5e51d8520
--- /dev/null
+++ b/dev-python/tifffile/tifffile-2022.10.10.ebuild
@@ -0,0 +1,56 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Read and write TIFF files"
+HOMEPAGE="
+ https://pypi.org/project/tifffile/
+ https://github.com/cgohlke/tifffile/
+ https://www.cgohlke.com/
+"
+SRC_URI="
+ https://github.com/cgohlke/tifffile/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/numpy-1.19.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/dask[${PYTHON_USEDEP}]
+ >=dev-python/fsspec-2021.5.0[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/xarray[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Internet
+ tests/test_tifffile.py::test_class_omexml
+ tests/test_tifffile.py::test_class_omexml_fail
+ tests/test_tifffile.py::test_class_omexml_modulo
+ tests/test_tifffile.py::test_class_omexml_attributes
+ tests/test_tifffile.py::test_class_omexml_multiimage
+ tests/test_tifffile.py::test_write_ome
+ tests/test_tifffile.py::test_write_ome_manual
+ # requires tons of free space
+ tests/test_tifffile.py::test_write_3gb
+ tests/test_tifffile.py::test_write_bigtiff
+ 'tests/test_tifffile.py::test_write_imagej_raw'
+ # TODO
+ tests/test_tifffile.py::test_issue_imagej_hyperstack_arg
+ tests/test_tifffile.py::test_issue_description_overwrite
+)