summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-12-05 23:56:16 +0100
committerPatrice Clement <monsieurp@gentoo.org>2016-12-05 23:57:32 +0100
commitba79e3731686192dbc3cc75313a84c899eeb190c (patch)
tree908a360472ad287918a4b06e9b6c29703e39d04c /dev-python/tinycss/tinycss-0.4.ebuild
parentsci-libs/libqalculate-0.9.9-r0: stable on alpha (diff)
downloadgentoo-ba79e3731686192dbc3cc75313a84c899eeb190c.tar.gz
gentoo-ba79e3731686192dbc3cc75313a84c899eeb190c.tar.bz2
gentoo-ba79e3731686192dbc3cc75313a84c899eeb190c.zip
dev-python/tinycss: version bump.
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/tinycss/tinycss-0.4.ebuild')
-rw-r--r--dev-python/tinycss/tinycss-0.4.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/tinycss/tinycss-0.4.ebuild b/dev-python/tinycss/tinycss-0.4.ebuild
new file mode 100644
index 000000000000..c778d6fe5bfc
--- /dev/null
+++ b/dev-python/tinycss/tinycss-0.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="A complete yet simple CSS parser for Python"
+HOMEPAGE="https://github.com/SimonSapin/tinycss/ http://packages.python.org/tinycss/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/lxml[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+DOCS=( CHANGES README.rst )
+RESTRICT="test"
+
+python_test() {
+ export TINYCSS_SKIP_SPEEDUPS_TESTS=1
+ local test
+ for test in ${PN}/tests/test_*.py; do
+ py.test $test || die
+ done
+}