summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-19 07:46:26 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-19 08:19:57 +0100
commit4470e707d686cb2989b2db21528e84a037157b77 (patch)
tree310bcc674888075072a7ba96450ff57d17401d69 /dev-python/tldextract
parentdev-python/hypothesis: Bump to 6.99.8 (diff)
downloadgentoo-4470e707d686cb2989b2db21528e84a037157b77.tar.gz
gentoo-4470e707d686cb2989b2db21528e84a037157b77.tar.bz2
gentoo-4470e707d686cb2989b2db21528e84a037157b77.zip
dev-python/tldextract: Bump to 5.1.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tldextract')
-rw-r--r--dev-python/tldextract/Manifest1
-rw-r--r--dev-python/tldextract/tldextract-5.1.2.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/tldextract/Manifest b/dev-python/tldextract/Manifest
index 2f165772b2a4..c0b5f739f5da 100644
--- a/dev-python/tldextract/Manifest
+++ b/dev-python/tldextract/Manifest
@@ -1 +1,2 @@
DIST tldextract-5.1.1.tar.gz 112645 BLAKE2B 3d4550f60c37769985f5e52ddcd8d93881759631a8a49c4588eee533da695d26c8b31294dd2b4f2456a14efe2a5af8e9573df18ab7eb54fe21a3c082c0615e59 SHA512 805266da1d66e9a8c43edc02014835abf691ab5b25262c63815a2e5b4d41c4e68944aafd35aad6abce650c762284e3a4281716c2d30c0e2d2c2ecccbb0139df9
+DIST tldextract-5.1.2.tar.gz 116825 BLAKE2B ffe10e58e122ac3a0d8851992d791d9525695d987d2c3bfcfe37df043bd532491e21b2e2530feab6d60befad7afb76b5e66d3ce16e909a0cd822a7cb37fa10f9 SHA512 79cdab6ec9259109bdee6412206eea1cd1d760e3c8ee3483607e27adc237821ff74039b2b3c886cb21ebd76f9d636e775623d018e06e46b713d76b9e9719fa00
diff --git a/dev-python/tldextract/tldextract-5.1.2.ebuild b/dev-python/tldextract/tldextract-5.1.2.ebuild
new file mode 100644
index 000000000000..cb6bb0083d41
--- /dev/null
+++ b/dev-python/tldextract/tldextract-5.1.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Accurately separate the TLD from the registered domain and subdomains of a URL"
+HOMEPAGE="
+ https://github.com/john-kurkowski/tldextract/
+ https://pypi.org/project/tldextract/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~loong ~x86"
+
+RDEPEND="
+ >=dev-python/filelock-3.0.8[${PYTHON_USEDEP}]
+ dev-python/idna[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-file-1.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # we don't need release tests, also deps
+ tests/test_release.py
+)