summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-18 09:15:26 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-18 10:18:56 +0100
commitd7958c541084486ec07c775c363bd3808e61d03f (patch)
tree788c71ef7572d6e47075e7e68da7fa670f44b773 /dev-python/tomlkit
parentdev-python/proto-plus: Bump to 1.20.3 (diff)
downloadgentoo-d7958c541084486ec07c775c363bd3808e61d03f.tar.gz
gentoo-d7958c541084486ec07c775c363bd3808e61d03f.tar.bz2
gentoo-d7958c541084486ec07c775c363bd3808e61d03f.zip
dev-python/tomlkit: Bump to 0.10.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tomlkit')
-rw-r--r--dev-python/tomlkit/Manifest1
-rw-r--r--dev-python/tomlkit/tomlkit-0.10.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/tomlkit/Manifest b/dev-python/tomlkit/Manifest
index ba5f95bcc597..69913d5edd7c 100644
--- a/dev-python/tomlkit/Manifest
+++ b/dev-python/tomlkit/Manifest
@@ -1,2 +1,3 @@
+DIST tomlkit-0.10.0.tar.gz 183499 BLAKE2B b9906dea2dd8867dca0208f3ce86b3d587f8504addfe25cf29f9164f50dc12d244010df53791ed01e0e7dd16e71ad77ce22c9ea7a37a6216880059c058f112e8 SHA512 05d03ae71a1d72ca0e03276f2b2530ca9fab7d6f366166a79839c66eaa00b55abb5f70a669ecb4d762dbbd655f10e4c4a373a7683cd781ae034d0910a0c3eccf
DIST tomlkit-0.8.0.tar.gz 179067 BLAKE2B 871eb8371d94c76552d78a56adfbde5ebb9da4b93aa29229ae9aa279ae35fac488a1b4986169b818d2e5366883b8f246b44dc9075d0d9785b2d7d6f97e222ec1 SHA512 77b267201021e740d8134d0d5edfbef2cf077adac0b320d80887fdedda3f63f74df1957e8230976f16c80fcc58fd4cfabb195cccf0eda7d6cd29f5f65d362147
DIST tomlkit-0.9.2.tar.gz 176380 BLAKE2B 3af0a397382c9c7dd948d32c3d359d8409b8c4a1beb93cb528632909ab834fb86298da1dd1791e474dd83395cf462e6ce6842c32ea3011ade744b495cf1fd40a SHA512 9a5a422ad7f2602d164b486dea816f878791393675a17ae30d10f12b6eed0ca73cbfaac7c359f1a57aea4f734b5ba31ee3bbbb95c521e41ce608eae972c2059b
diff --git a/dev-python/tomlkit/tomlkit-0.10.0.ebuild b/dev-python/tomlkit/tomlkit-0.10.0.ebuild
new file mode 100644
index 000000000000..4de45e362c79
--- /dev/null
+++ b/dev-python/tomlkit/tomlkit-0.10.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Style preserving TOML library"
+HOMEPAGE="https://github.com/sdispater/tomlkit"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="test? ( dev-python/pyyaml[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ # use setup.py to avoid circular dep with poetry-core
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["setuptools", "wheel"]
+ build-backend = "setuptools.build_meta"
+ EOF
+}