summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-25 09:06:03 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-25 09:42:54 +0200
commit45c709a78ac7359d47551c0501dda631858a9b45 (patch)
tree040887ac0bfb91a2cb39a578f36870ecab52b976 /dev-python/traitlets/traitlets-5.12.0.ebuild
parentdev-python/jupyter-client: Bump to 8.5.0 (diff)
downloadgentoo-45c709a78ac7359d47551c0501dda631858a9b45.tar.gz
gentoo-45c709a78ac7359d47551c0501dda631858a9b45.tar.bz2
gentoo-45c709a78ac7359d47551c0501dda631858a9b45.zip
dev-python/traitlets: Bump to 5.12.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/traitlets/traitlets-5.12.0.ebuild')
-rw-r--r--dev-python/traitlets/traitlets-5.12.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/traitlets/traitlets-5.12.0.ebuild b/dev-python/traitlets/traitlets-5.12.0.ebuild
new file mode 100644
index 000000000000..a8fb08eb8a28
--- /dev/null
+++ b/dev-python/traitlets/traitlets-5.12.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A configuration system for Python applications"
+HOMEPAGE="
+ https://github.com/ipython/traitlets/
+ https://pypi.org/project/traitlets/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+BDEPEND="
+ test? (
+ >=dev-python/argcomplete-2.0[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ dev-python/myst-parser \
+ dev-python/pydata-sphinx-theme
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ tests/test_typing.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pytest_mock
+}