summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/traits
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/traits')
-rw-r--r--dev-python/traits/Manifest1
-rw-r--r--dev-python/traits/metadata.xml22
-rw-r--r--dev-python/traits/traits-4.5.0.ebuild37
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/traits/Manifest b/dev-python/traits/Manifest
new file mode 100644
index 000000000000..7fb3adc76758
--- /dev/null
+++ b/dev-python/traits/Manifest
@@ -0,0 +1 @@
+DIST traits-4.5.0.tar.gz 4853612 SHA256 5293a8786030b0b243e059f52004355b6939d7c0f1be2eb5a605b63cca484c84 SHA512 d506b4395395898eb824896d299bfcde609e100025cf9a55cd7d7c47615545efd3b007e46549e564fbfb2d5882b36ae676843f211f168b2557c504849c5ef582 WHIRLPOOL fc9a1c41d09579df7cbb63ba17696b343bda707f0f95a2a5dd289b36fa4ded8088ea46f03259f616d9f081ff20fbce208adbc7913e0466ee6de56bc7e08718ae
diff --git a/dev-python/traits/metadata.xml b/dev-python/traits/metadata.xml
new file mode 100644
index 000000000000..f5194078267d
--- /dev/null
+++ b/dev-python/traits/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+<longdescription lang="en">
+ The traits package from the Enthought Tool Suite provides a
+ metaclass with special attributes that are called traits. A trait
+ is a type definition that can be used for normal Python object
+ attributes, giving the attributes some additional characteristics:
+ * Initialization: A trait attribute can have a default value
+ * Validation: A trait attribute is manifestly typed.
+ * Delegation: The value of a trait attribute can be contained in another
+ object
+ * Notification: Setting the value of a trait attribute can fired
+ callbacks
+ * Visualization: With the TraitsUI package, GUIs can be generated
+ automatically from traited objects.
+</longdescription>
+<upstream>
+ <remote-id type="pypi">traits</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/dev-python/traits/traits-4.5.0.ebuild b/dev-python/traits/traits-4.5.0.ebuild
new file mode 100644
index 000000000000..388d99d83d38
--- /dev/null
+++ b/dev-python/traits/traits-4.5.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Enthought Tool Suite: Explicitly typed attributes for Python"
+HOMEPAGE="http://code.enthought.com/projects/traits/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )"
+
+python_prepare_all() {
+ sed -i -e "s/'-O3'//g" setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ distutils-r1_python_compile
+}
+
+python_test() {
+ cd "${BUILD_DIR}"/lib || die
+ nosetests || die
+}