summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-08 00:40:14 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-08 01:11:22 +0200
commit87b54613f00ee435b3a4dce17eebcb1ca350c985 (patch)
treede53bab59fcd2ac31967159d1c336155ad9bb362 /dev-python/transitions/transitions-0.8.8.ebuild
parentdev-python/pikepdf: Bump to 2.11.0 (diff)
downloadgentoo-87b54613f00ee435b3a4dce17eebcb1ca350c985.tar.gz
gentoo-87b54613f00ee435b3a4dce17eebcb1ca350c985.tar.bz2
gentoo-87b54613f00ee435b3a4dce17eebcb1ca350c985.zip
dev-python/transitions: Bump to 0.8.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/transitions/transitions-0.8.8.ebuild')
-rw-r--r--dev-python/transitions/transitions-0.8.8.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/transitions/transitions-0.8.8.ebuild b/dev-python/transitions/transitions-0.8.8.ebuild
new file mode 100644
index 000000000000..baacbad3ee0a
--- /dev/null
+++ b/dev-python/transitions/transitions-0.8.8.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A lightweight, object-oriented state machine implementation in Python"
+HOMEPAGE="https://github.com/pytransitions/transitions"
+SRC_URI="https://github.com/pytransitions/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="
+ || (
+ dev-python/pygraphviz[${PYTHON_USEDEP}]
+ dev-python/graphviz[${PYTHON_USEDEP}]
+ )
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+DEPEND="
+ test? (
+ dev-python/dill[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pycodestyle[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_install() {
+ distutils-r1_src_install
+
+ use examples && dodoc examples/*.ipynb
+}