summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-19 04:53:00 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-19 05:49:15 +0200
commitcccff7fa1fd64b27ef73e4fdf28133973c7e28f5 (patch)
tree0d2e2a880e94f277805ac7c5f47ca5da50c88b6a /dev-python/trove-classifiers
parentapp-crypt/fcrackzip: commit missing patch (diff)
downloadgentoo-cccff7fa1fd64b27ef73e4fdf28133973c7e28f5.tar.gz
gentoo-cccff7fa1fd64b27ef73e4fdf28133973c7e28f5.tar.bz2
gentoo-cccff7fa1fd64b27ef73e4fdf28133973c7e28f5.zip
dev-python/trove-classifiers: Bump to 2022.10.19
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/trove-classifiers')
-rw-r--r--dev-python/trove-classifiers/Manifest1
-rw-r--r--dev-python/trove-classifiers/trove-classifiers-2022.10.19.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/trove-classifiers/Manifest b/dev-python/trove-classifiers/Manifest
index 1ebd11384aee..c2d55331defe 100644
--- a/dev-python/trove-classifiers/Manifest
+++ b/dev-python/trove-classifiers/Manifest
@@ -1,2 +1,3 @@
+DIST trove-classifiers-2022.10.19.gh.tar.gz 15030 BLAKE2B c5841fd36070979577fe154559d7c578cbef0166bb933cef0b2945581a388602c65a0711320b610ac9acd4166784ec616f1e4d532453488ddf7b933f5fac124b SHA512 5e7319028d16f917c7ddbc997f2082f3e5816dd1f93038c2193aa70a74e2e47f5bf72d8d205453fb2e0ddae3fe56affc0c78930b11767d2d55db0910a454568d
DIST trove-classifiers-2022.8.31.gh.tar.gz 15020 BLAKE2B 3898164f5afe8c381894b7dfb07b0b2f5fb9f20b2b8b450bbde5651d71989cb39de674364e298e3fa67011a2f8f13c099bf92d67e4e79da33ac5e90e078af155 SHA512 bce304ca9d4b4b7a40272e69f4805de9798987baee2c14983fc809daa32b6c06479d1e24c64599228f3c6f3fa79709a2fee9b6661fdbcb40d539689e4fdd1595
DIST trove-classifiers-2022.9.26.gh.tar.gz 15029 BLAKE2B f1a6dbee8dc03de54d4c5a9b61ab8493bf8ab8369d3ca99a1505459eaf4383f07246320d46a4aa2b75f2bae835932d28ed45ac983c47805dddd2c7ae3d86f647 SHA512 32fc05d993adb7c6056153c9250fcae519aae47f9b7b38a41c4bfec2f304d4bd1a7655d709ea387b887ec6a5a33b31b8dfa6edb112fb91453f8d4831d16baf98
diff --git a/dev-python/trove-classifiers/trove-classifiers-2022.10.19.ebuild b/dev-python/trove-classifiers/trove-classifiers-2022.10.19.ebuild
new file mode 100644
index 000000000000..964617661415
--- /dev/null
+++ b/dev-python/trove-classifiers/trove-classifiers-2022.10.19.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Canonical source for classifiers on PyPI (pypi.org)"
+HOMEPAGE="
+ https://github.com/pypa/trove-classifiers/
+ https://pypi.org/project/trove-classifiers/
+"
+SRC_URI="
+ https://github.com/pypa/trove-classifiers/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ dev-python/calver[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest
+ "${EPYTHON}" -m tests.lib || die
+}