summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-11-22 13:23:21 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-11-22 13:23:21 -0800
commit6522f8504718aeedb0f8a2ea60717bd0d80a3d3e (patch)
tree778dac697656fc7162e224ba72f06f69512f8c07 /dev-python/twine/twine-1.15.0.ebuild
parentnet-misc/gerbera: Version bump (diff)
downloadgentoo-6522f8504718aeedb0f8a2ea60717bd0d80a3d3e.tar.gz
gentoo-6522f8504718aeedb0f8a2ea60717bd0d80a3d3e.tar.bz2
gentoo-6522f8504718aeedb0f8a2ea60717bd0d80a3d3e.zip
dev-python/twine: Version bump to 1.15.0
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/twine/twine-1.15.0.ebuild')
-rw-r--r--dev-python/twine/twine-1.15.0.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/twine/twine-1.15.0.ebuild b/dev-python/twine/twine-1.15.0.ebuild
new file mode 100644
index 000000000000..c4de1ffe7f13
--- /dev/null
+++ b/dev-python/twine/twine-1.15.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of utilities for publishing packages on PyPI"
+HOMEPAGE="https://twine.readthedocs.io/ https://github.com/pypa/twine https://pypi.org/project/twine/"
+SRC_URI="https://github.com/pypa/twine/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pretend[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}
+ >=dev-python/tqdm-4.14[${PYTHON_USEDEP}]
+ >=dev-python/pkginfo-1.4.2[${PYTHON_USEDEP}]
+ >=dev-python/readme_renderer-21.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-0.8.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/pyblake2[${PYTHON_USEDEP}]' python{2_7,3_5})
+"
+
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}/twine-1.15.0-tests.patch"
+)
+
+python_prepare_all() {
+ # requires internet
+ rm -f tests/test_integration.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ distutils_install_for_testing
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}