summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-04-24 10:16:09 +0200
committerMichał Górny <mgorny@gentoo.org>2020-04-24 10:18:57 +0200
commitf646e1f7474a0d4e2a284c73d7acb0e105fca0f0 (patch)
tree117caa7987124a1a097f8b0da4669dcf485250a9 /dev-python/twisted/twisted-19.10.0.ebuild
parentprofiles/profiles.desc: Fix space indents (diff)
downloadgentoo-f646e1f7474a0d4e2a284c73d7acb0e105fca0f0.tar.gz
gentoo-f646e1f7474a0d4e2a284c73d7acb0e105fca0f0.tar.bz2
gentoo-f646e1f7474a0d4e2a284c73d7acb0e105fca0f0.zip
dev-python/twisted: Run tests in virtx to avoid crashing
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/twisted/twisted-19.10.0.ebuild')
-rw-r--r--dev-python/twisted/twisted-19.10.0.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/twisted/twisted-19.10.0.ebuild b/dev-python/twisted/twisted-19.10.0.ebuild
index 7dc1cb2ddc54..1fedad603686 100644
--- a/dev-python/twisted/twisted-19.10.0.ebuild
+++ b/dev-python/twisted/twisted-19.10.0.ebuild
@@ -6,7 +6,7 @@ EAPI=7
PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
PYTHON_REQ_USE="threads(+)"
-inherit distutils-r1
+inherit distutils-r1 virtualx
TWISTED_PN="Twisted"
TWISTED_P="${TWISTED_PN}-${PV}"
@@ -98,6 +98,10 @@ python_prepare_all() {
distutils-r1_python_prepare_all
}
+src_test() {
+ virtx distutils-r1_src_test
+}
+
python_test() {
distutils_install_for_testing