summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2020-01-14 06:12:24 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2020-01-14 06:14:33 +0100
commit3d4dba214c2ca968962be1c0720d376b33d043bf (patch)
treeb2ff1f3e1bb286ea0dd320cc9dba85991a53be45 /dev-python/typed-ast
parentapp-office/libreoffice-bin-debug: Version bump 6.3.4.2 with boost 1.72.0 (diff)
downloadgentoo-3d4dba214c2ca968962be1c0720d376b33d043bf.tar.gz
gentoo-3d4dba214c2ca968962be1c0720d376b33d043bf.tar.bz2
gentoo-3d4dba214c2ca968962be1c0720d376b33d043bf.zip
Revert "dev-python/typed-ast: Remove redundant versions"
Still needed for dev-python/mypy ... This reverts commit 0278c9ef72411d1036ce0cbc3221a9b11252ae3c. Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-python/typed-ast')
-rw-r--r--dev-python/typed-ast/Manifest3
-rw-r--r--dev-python/typed-ast/typed-ast-1.1.0.ebuild16
-rw-r--r--dev-python/typed-ast/typed-ast-1.2.0.ebuild18
-rw-r--r--dev-python/typed-ast/typed-ast-1.3.1.ebuild18
4 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/typed-ast/Manifest b/dev-python/typed-ast/Manifest
index 3c59673bf7d9..d1cf53bd7b70 100644
--- a/dev-python/typed-ast/Manifest
+++ b/dev-python/typed-ast/Manifest
@@ -1,2 +1,5 @@
+DIST typed-ast-1.1.0.tar.gz 200587 BLAKE2B 09dd6d65513a37a57ecb6df2a505100f5fc08a49a244f1cb83af363d20d9b1b76f127ec5da6ef115a56ae6dc560ab40dcaae4740385fdd9e305bfd2ec26fdbaf SHA512 439e949082ee5cb9434fec99021c08401a46ec2ad16d96296c6440aa1fd8158f6605efbdfa55e536c3fddd4018bb0f4c5ee4d5a4a32954242b7902b9ce3463f2
+DIST typed-ast-1.2.0.tar.gz 202702 BLAKE2B 79e919019763f4af0a2f24108cfa418693dc5a1d791a0045a49fb128d715f91ec5bcca6d4bb6812e19b7a5438bcb27d239f2aba7de8b859d4e8e73027c59665f SHA512 801f59cdce48f7be3045c44d207a5a269bc1cd5ca9f0536d3d16f10ce82794a7e5cd5d3c83982927cebc52e1b1dbd47532140bcedca0ca4ace45b726aa0343ee
+DIST typed-ast-1.3.1.tar.gz 204285 BLAKE2B 209911e0dc7291ec4b48ce7c5163d738ccd0978027d2bb1b64004c0f08feb7567d83ba8f04dfe48975ecc2116ee365a903f455dddcaf1bc07cf5deb08572f92c SHA512 390547485878ccb7e3a168e24b8b63c1784888ecedfae980562c3c0c0073c73ebef27190feeac99745c205d18061ffe5e3eb0830068968176ef2a06fd3ae4b2a
DIST typed_ast-1.4.0.tar.gz 206620 BLAKE2B 59d3ed516b63643e37d9530dcb82670dd0e36f436650880f9fb304d081c3a72ecd494646dbf8f62fe95d2e70742390a5be711bcb803f1f0b6524dec1bf43c8c3 SHA512 b74e7fc51cde16439eae7cf41f0bdb95b5998362eccb73cf736f343cdab64daab63bc0f95f05a4911b229761749bdd31ac83423b58f2f3e1e1dadc7e6015bc1c
DIST typed_ast-1.4.1.tar.gz 208587 BLAKE2B db874caf459cb73345305051a7c4e97244e92b28e94e82f59b38bb91b7c6c69a2531a81c84d483eca8d641bc947f6aa1b98ba59cd880f7560fbdec55bce41787 SHA512 a3154fe723aeadf998694aba0faf516e5b9abb876e4c7d91843b3694474ff6911b3e77a6cb7366cfa8e5a573b331906b6a0b134b25627aaba0dcbe92c4e25590
diff --git a/dev-python/typed-ast/typed-ast-1.1.0.ebuild b/dev-python/typed-ast/typed-ast-1.1.0.ebuild
new file mode 100644
index 000000000000..7c70025fe0f0
--- /dev/null
+++ b/dev-python/typed-ast/typed-ast-1.1.0.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_6 )
+inherit distutils-r1
+
+DESCRIPTION="A fork of Python 2 and 3 ast modules with type comment support"
+HOMEPAGE="https://github.com/python/typed_ast"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
diff --git a/dev-python/typed-ast/typed-ast-1.2.0.ebuild b/dev-python/typed-ast/typed-ast-1.2.0.ebuild
new file mode 100644
index 000000000000..439c03c60dcf
--- /dev/null
+++ b/dev-python/typed-ast/typed-ast-1.2.0.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Python typed-ast backported"
+HOMEPAGE="https://pypi.org/project/typed-ast/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/typed-ast/typed-ast-1.3.1.ebuild b/dev-python/typed-ast/typed-ast-1.3.1.ebuild
new file mode 100644
index 000000000000..c8a10e8068a2
--- /dev/null
+++ b/dev-python/typed-ast/typed-ast-1.3.1.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Python typed-ast backported"
+HOMEPAGE="https://pypi.org/project/typed-ast/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0 MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"