summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-04-16 17:39:43 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-04-16 18:36:13 +0300
commit6dc336138e12fafd1a7fa90b7569b49c348191f7 (patch)
treea98f95c1c4266daa25af3b4d10d73302ffb4dcd8 /dev-python/typed-ast
parentdev-python/markdown-it-py: add 2.1.0 (diff)
downloadgentoo-6dc336138e12fafd1a7fa90b7569b49c348191f7.tar.gz
gentoo-6dc336138e12fafd1a7fa90b7569b49c348191f7.tar.bz2
gentoo-6dc336138e12fafd1a7fa90b7569b49c348191f7.zip
dev-python/typed-ast: add 1.5.3
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/typed-ast')
-rw-r--r--dev-python/typed-ast/Manifest1
-rw-r--r--dev-python/typed-ast/typed-ast-1.5.3.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/typed-ast/Manifest b/dev-python/typed-ast/Manifest
index 7232d0585f5b..9e3fd536c1a3 100644
--- a/dev-python/typed-ast/Manifest
+++ b/dev-python/typed-ast/Manifest
@@ -1,2 +1,3 @@
DIST typed_ast-1.4.3.tar.gz 210893 BLAKE2B 9e0bbaac73d97c13303c783d4e91b015570d9b9ad74361e1bcfe67259982459003ea6c24602ce004fe1447c4375090d5fa58006e18af28da256f6b25d9aa20b1 SHA512 7ac06e277c883afd1a7161601ffca0114aa63db257695a4bf4c64d819a7192fe52167edb57991aefc7accc6a9902b5faf2ba9e4032c4b9be31f1db7a091607c9
DIST typed_ast-1.5.2.tar.gz 252310 BLAKE2B c36ab31e4c266de38a07935fc72ece62087bc52a6ebde401f9b2dcc641af064828572fa6e903dbdfb0c573ced10686b8dba995d316a5f7a7ee68efd3a4e9520c SHA512 7da72fc0c4fcb74cb41914765baea5c7f52b1e8a5c58883877e702765be59d3dd8c7f73bd5759a65781d04fdecbcf46160ff4402578a92685f25163e12b93558
+DIST typed_ast-1.5.3.tar.gz 252510 BLAKE2B e258b6c931d31a528091be2e5f7f9bf55f7fa48a14221a95e77924c18879480a34cd8293f9c1125810a43ab001195da2b36637aaee2c9b895b346cc94cab6577 SHA512 481fffc79d99f1f7c0009a9a4f9151745d17269827ea6306f35a015dc9e4cc3d85068948e157076fecff87d9301c18f637edfe7f26d63779ccfe38bf10105969
diff --git a/dev-python/typed-ast/typed-ast-1.5.3.ebuild b/dev-python/typed-ast/typed-ast-1.5.3.ebuild
new file mode 100644
index 000000000000..8a0f2077cd67
--- /dev/null
+++ b/dev-python/typed-ast/typed-ast-1.5.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Python typed-ast backported"
+HOMEPAGE="https://pypi.org/project/typed-ast/ https://github.com/python/typed_ast"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN/-/_}/${P/-/_}.tar.gz"
+S="${WORKDIR}/${P/-/_}"
+
+LICENSE="Apache-2.0 MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+
+distutils_enable_tests pytest
+
+python_test() {
+ cd "${BUILD_DIR}" || die
+ epytest
+}