summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-15 07:22:21 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-15 08:16:15 +0100
commit96a3957a61db80218c0f9c39e63a74d8ad318e96 (patch)
tree1175785ce8ecbfb3c5810179f5189a1bc62f225f /dev-python/typing-extensions/typing-extensions-4.5.0.ebuild
parentapp-admin/awscli: Bump to 1.27.71 (diff)
downloadgentoo-96a3957a61db80218c0f9c39e63a74d8ad318e96.tar.gz
gentoo-96a3957a61db80218c0f9c39e63a74d8ad318e96.tar.bz2
gentoo-96a3957a61db80218c0f9c39e63a74d8ad318e96.zip
dev-python/typing-extensions: Bump to 4.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/typing-extensions/typing-extensions-4.5.0.ebuild')
-rw-r--r--dev-python/typing-extensions/typing-extensions-4.5.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/typing-extensions/typing-extensions-4.5.0.ebuild b/dev-python/typing-extensions/typing-extensions-4.5.0.ebuild
new file mode 100644
index 000000000000..b036b91b4a48
--- /dev/null
+++ b/dev-python/typing-extensions/typing-extensions-4.5.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+MY_P=${P/-/_}
+DESCRIPTION="Backported and Experimental Type Hints for Python 3.7+"
+HOMEPAGE="
+ https://pypi.org/project/typing-extensions/
+ https://github.com/python/typing_extensions/
+"
+SRC_URI="
+ https://github.com/python/typing_extensions/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+
+distutils_enable_tests unittest
+
+python_test() {
+ cd src || die
+ eunittest
+}