summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2025-01-24 07:07:04 +0100
committerMichał Górny <mgorny@gentoo.org>2025-01-24 08:16:32 +0100
commit341ff0bc6bf3e87548fd7f98cc48e077d6784f12 (patch)
tree9422ed5be64e402f847582b4938186e2ccdf2ccc /dev-python/uv
parentsys-kernel/gentoo-kernel-bin: Bump to 5.15.177 (diff)
downloadgentoo-341ff0bc6bf3e87548fd7f98cc48e077d6784f12.tar.gz
gentoo-341ff0bc6bf3e87548fd7f98cc48e077d6784f12.tar.bz2
gentoo-341ff0bc6bf3e87548fd7f98cc48e077d6784f12.zip
dev-python/uv: Bump to 0.5.24
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/uv')
-rw-r--r--dev-python/uv/Manifest1
-rw-r--r--dev-python/uv/uv-0.5.24.ebuild170
2 files changed, 171 insertions, 0 deletions
diff --git a/dev-python/uv/Manifest b/dev-python/uv/Manifest
index 5afe62f8066a..51d512c029c5 100644
--- a/dev-python/uv/Manifest
+++ b/dev-python/uv/Manifest
@@ -11,5 +11,6 @@ DIST uv-0.5.21.gh.tar.gz 3260658 BLAKE2B 064f52d4c690d2992988ca1683ce2c5183c2662
DIST uv-0.5.22-crates.tar.xz 53858800 BLAKE2B c5b6ee71e1e8dfbfa053f6c0d29515c8a16d4bc16c8625f8890ca4f62b603230981c872bb9e9a3cb8960105f6c0ba5331c97a373d3242ea17c5d3302342b844d SHA512 fae1412a761953b0bc19229f959366222d8af2a15bb2c60feb1174639d3b78bb62ed0eab55ed09b6da796fb945d4c9b60120a8a5cbb327a080ff46be76eace23
DIST uv-0.5.22.gh.tar.gz 3302316 BLAKE2B 13cb21c5c1b3961bb5d34e744e17580ec45a9dc22f22d1d589109d9fb3378aafe882f551855bde8050778e49784e3748ebf9f90eaafc3d64571974d34d235a68 SHA512 57b84f8da8867e013d3bffd581f3d2b7bc730ab9dcccc2020e00a4f4c8c5848546461a8c15ec06581115aabc0b765db2ff2ab7048aa15bf485d0fff2c130d546
DIST uv-0.5.23.gh.tar.gz 3311484 BLAKE2B bf7feb6d34a39358326a7a13053139179ca1d636b414286204180e1d0d314d6a38dc823e1d29321f815886155c6ee5c207402f2a77984573ca0ce32670370951 SHA512 483be9e257169a3818a3a6e923601c9ff50654e23d30968253229cb11aed12f1d553e33133d1e58d77e6ce7cb7d5909dac61601d978199e2ba0879bf2e4aa658
+DIST uv-0.5.24.gh.tar.gz 3319136 BLAKE2B a75ca99fcd1f5ccefc0e22e421b1f9da0e01a394a5a9015a364dfdf775240210e58098fa3996ba1c190550f2ce33aadcbe2395b689cb2b77726b9af3125ac7c7 SHA512 9cb55bdb163c491b0fd1fe9d9a2f41d8e64b5b93e4458a4fd703191e19b8babf03196a544266c72fff2a7af1805a60cc6fa405d0397fb9a1a51c71efd75df85a
DIST uv-0.5.6-crates.tar.xz 46263172 BLAKE2B 73b1d2dc957f89f923dda09a8c038426041292c442ce253ff9110f996cd1e1f892a5a438d8e1c894fc0d823401cced0ddc8ad88b5e6a83199af7055a04ce85dc SHA512 c9d4f8085416bffb1e1872fd907d15a50cae0c0c5fba994d27b3acdc3c836dffd771558246573af4bb7467353a031ea56018d5ae1fbdffa4f63988462de00343
DIST uv-0.5.6.gh.tar.gz 2952255 BLAKE2B b815b60b99f959751f5839365b8b210919247ad99bff93ee4d202bc152bd06b83a62914cfbf341bfddb5b2c87d9e546c5e2a6d1baff1599d0218160ee89de504 SHA512 fc8c7f4f60a3d2ce997341450daf20ad039ef379ac5dd4575f8db0327284bd8278419b66f8f9695f2701a9579ab004b5b60476bd8dc4c27314211f795118bc5a
diff --git a/dev-python/uv/uv-0.5.24.ebuild b/dev-python/uv/uv-0.5.24.ebuild
new file mode 100644
index 000000000000..1be33b3920b3
--- /dev/null
+++ b/dev-python/uv/uv-0.5.24.ebuild
@@ -0,0 +1,170 @@
+# Copyright 2024-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CRATES="
+"
+
+declare -A GIT_CRATES=(
+ [async_zip]='https://github.com/charliermarsh/rs-async-zip;c909fda63fcafe4af496a07bfda28a5aae97e58d;rs-async-zip-%commit%'
+ [pubgrub]='https://github.com/astral-sh/pubgrub;648aa343486e5529953153781fc86025c73c4a61;pubgrub-%commit%'
+ [tl]='https://github.com/astral-sh/tl;6e25b2ee2513d75385101a8ff9f591ef51f314ec;tl-%commit%'
+ [version-ranges]='https://github.com/astral-sh/pubgrub;648aa343486e5529953153781fc86025c73c4a61;pubgrub-%commit%/version-ranges'
+)
+
+RUST_MIN_VER="1.83.0"
+
+inherit cargo check-reqs
+
+CRATE_PV=0.5.22
+DESCRIPTION="A Python package installer and resolver, written in Rust"
+HOMEPAGE="
+ https://github.com/astral-sh/uv/
+ https://pypi.org/project/uv/
+"
+# pypi sdist misses scripts/, needed for tests
+SRC_URI="
+ https://github.com/astral-sh/uv/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ ${CARGO_CRATE_URIS}
+"
+if [[ ${PKGBUMPING} != ${PVR} ]]; then
+ SRC_URI+="
+ https://dev.gentoo.org/~mgorny/dist/uv-${CRATE_PV}-crates.tar.xz
+ "
+fi
+
+# most of the code
+LICENSE="|| ( Apache-2.0 MIT )"
+# crates/pep508-rs is || ( Apache-2.0 BSD-2 ) which is covered below
+# Dependent crate licenses
+LICENSE+="
+ 0BSD Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD-2 BSD ISC MIT
+ MPL-2.0 Unicode-3.0 Unicode-DFS-2016 ZLIB
+"
+# ring crate
+LICENSE+=" openssl"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="test"
+PROPERTIES="test_network"
+
+DEPEND="
+ app-arch/bzip2:=
+ app-arch/xz-utils:=
+ app-arch/zstd:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ test? (
+ dev-lang/python:3.8
+ dev-lang/python:3.9
+ dev-lang/python:3.10
+ dev-lang/python:3.11
+ dev-lang/python:3.12
+ !!~dev-python/uv-0.5.0
+ )
+"
+
+QA_FLAGS_IGNORED="usr/bin/.*"
+
+check_space() {
+ local CHECKREQS_DISK_BUILD=3G
+ use debug && CHECKREQS_DISK_BUILD=9G
+ check-reqs_pkg_setup
+}
+
+pkg_pretend() {
+ check_space
+}
+
+pkg_setup() {
+ check_space
+ rust_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # enable system libraries where supported
+ export ZSTD_SYS_USE_PKG_CONFIG=1
+ # TODO: unbundle libz-ng-sys, tikv-jemalloc-sys?
+
+ # remove unbundled sources, just in case
+ find "${ECARGO_VENDOR}"/{bzip2,lzma,zstd}-sys-*/ -name '*.c' -delete || die
+
+ # bzip2-sys requires a pkg-config file
+ # https://github.com/alexcrichton/bzip2-rs/issues/104
+ mkdir "${T}/pkg-config" || die
+ export PKG_CONFIG_PATH=${T}/pkg-config${PKG_CONFIG_PATH+:${PKG_CONFIG_PATH}}
+ cat >> "${T}/pkg-config/bzip2.pc" <<-EOF || die
+ Name: bzip2
+ Version: 9999
+ Description:
+ Libs: -lbz2
+ EOF
+}
+
+src_configure() {
+ local myfeatures=(
+ git
+ pypi
+ python
+ )
+
+ cargo_src_configure --no-default-features
+}
+
+src_compile() {
+ cd crates/uv || die
+ cargo_src_compile
+}
+
+src_test() {
+ # work around https://github.com/astral-sh/uv/issues/4376
+ local -x PATH=${BROOT}/usr/lib/python-exec/python3.12:${PATH}
+ local -x COLUMNS=100
+ local -x PYTHONDONTWRITEBYTECODE=
+ # fix tests failing because of our config
+ local -x XDG_CONFIG_DIRS=${T}
+
+ cd crates/uv || die
+ cargo_src_test --no-fail-fast
+}
+
+src_install() {
+ cd crates/uv || die
+ cargo_src_install
+
+ insinto /etc/xdg/uv
+ newins - uv.toml <<-EOF || die
+ # These defaults match Fedora, see:
+ # https://src.fedoraproject.org/rpms/uv/pull-request/18
+
+ # By default ("automatic"), uv downloads missing Python versions
+ # automatically and keeps them in the user's home directory.
+ # Disable that to make downloading opt-in, and especially
+ # to avoid unnecessarily fetching custom Python when the distro
+ # package would be preferable. Python builds can still be
+ # downloaded manually via "uv python install".
+ #
+ # https://docs.astral.sh/uv/reference/settings/#python-downloads
+ python-downloads = "manual"
+
+ # By default ("managed"), uv always prefers self-installed
+ # Python versions over the system Python, independently
+ # of versions. Since we generally expect users to use that
+ # to install old Python versions not in ::gentoo anymore,
+ # this effectively means that uv would end up preferring very
+ # old Python versions over the newer ones that are provided
+ # by the system. Default to using the system versions to avoid
+ # this counter-intuitive behavior.
+ #
+ # https://docs.astral.sh/uv/reference/settings/#python-preference
+ python-preference = "system"
+ EOF
+}